My first 2 disasterous evenings with Node-RED

Hello all,

This is my first post and second day using Node-RED.

Yesterday, after a few hours I had a dashboard with a couple of guages displaying the data of a couple of Arduino MODBUS servers. The Modbus client is an S7 PLC watering the plants in my polytunnel. This has been trouble free for almost 4 years.

Last night, I even managed to configure an email node to forward a water tank level to a couple of my email addresses. After a few dozen exciting emails '[79]', my water tank level as %, I was getting a message 'failed to deploy, device full, write' or similar. I tried deleting all the nodes but no more fun was to be had. I tried to reboot my Raspberry Pi 3 B+ but it would hang at the point just before the desktop would normally appear. Several hours on Google and a few things to try later and I decided to reinstall the latest NOOBS when I got home this evening. after about 4 hours I had my Pi close to where it was last night, albeit with the very latest NOOBS, Arduino IDE, etc.
I used the script on the Node-RED website to remove the pre-installed Node-Red and update to the latest. I was back to enjoying Node-RED. I tried to recreate my simple dashboard but after only 10 minutes or so I could no longer load my workspace or dashboard in the browser. It behaves exactly like when there is no internet connection, 'page cannot be reached'. I have access to any web page I try but cannot get the Node-RED workspace to load. The Node-RED console is running and I see the IP of the Modbus server in the text. I see ....status1 Failure... In the scrolling screen. I have no firewall or proxy settings that were changed.

My first question is 'why did it stop working after only 10 minutes?

My second question is 'how do I clear what is happening in the console so that I can try again?

I am totally inspired by all the weird and wonderful things people around the world are achieving. Unfortunately, I have no peers who may be able to help. None of my friends or colleagues have heard about Node-RED until today.

I have not found a similar issue on Google so I thought I'd introduce myself to the forum.

Namaste, Matt

device full sounds like the sd card is full or corrupted.

What size is it? Did you follow the pi instructions to enlarge it?
If you did and the size is large enough where did you buy it? Auction sites etc are notorious for cards that look like they are one size and are actually a lot smaller.

1 Like

Also show us what the command

Hi, yes, I suspected that the SD card was indeed full, (I failed miserably at installing Wordpress database, but that was many months ago). I recall that I used the email 'in' node, which I think loaded my entire inbox and stuffed the card..

This is why I didn't hesitate to follow the instructions for reformatting the SD card and loading it with the latest NOOBS. The 2 cards I have here are both 16G and are from the PiHut.

I will try 'df' later today. Do I simply type 'df' into terminal?

And I will look for a list of these commands.

Thank you

Yes, it stands for Disk Free and will show you the space on all the partitions.
There is an option in raspi-config to let the system grab any unused space on the SD card. Run df first to see how much you have though.

possibly use df -h instead, -h makes it print more human readable units

Thank you. This is a great little command

and if you do find you are low on disk space

du -h will show you how much space each directory is taking


Ace, thank you

So did you sort your problem?

I have found the Pi to be an unrelaible platform with NR and encountered similar failures. I moved everything to the BeagleBoneBlacks - flashing them instead of running from SD, my stuff has been running solid for almost 2 years, havn't replaced any of them. Might be worth looking into.

I think you are in a minority in that respect. I believe most find that a Pi + node-red is an extremely reliable combination, provided you use good quality SD cards and power supplies.


Had a pi running Node-RED without any issues for 4 years. As Colin says with a known-sourced SD card and a correctly spec’d power supply I have found then to very reliable


I put NOOBS 3.1.1 on the card Colin, ‘it’ is working great now thanks.

As others have said, you are totally in a minority. The Pi is VERY reliable. I have 2 running (a Pi2 and a Pi3). I can't even remember when I started them up but it has certainly been years now.

Most Pi problems stem from poor power supplies & cheap SD-cards.

There is a massive difference in cost between a Pi and a Black. So it is to be hoped that you would get something for that money. My 2 live Pi's cost less than a single Black. Reliability isn't likely to be one of the things though.

Both are mighty fine platforms. The actual cost differential is (or was when the pound was worth something) not very great once you had factored in the built in eMMC vs cost of a decent quality SD card, and the fact it has analogue pins etc. I hope Rob Nelson won'r mind me saying he does a fantastic job keeping up with Node-RED releases on it so that it comes pre-baked on that platform also.

Sometimes it is just luck of the draw and timing as to which you end up preferring.

I understand, you guys don't have to get all hot and bothered. I said "I have found it to be un-reliable". I get that many people are running things fine with their pi's. You guys are betting on SD card quality vs emmc. The cost difference is negligible when compared to a PLC and its made by texas instruments (who has made reliable lab equipement for years). I have NEVER had a BBB act up but I have had the black screen crap and boot issues with the Pi, if its a PSU problem then my industrial psu doesn't work well with the PI, which makes little sense given the quality of industrial power supplies. I think its just not the right platform for my application is all and I was merely suggesting an alternative. I didn't realize the PI fan-boys were so strong in here. :slight_smile: I've also run NR great on ARM based industrial PC's. PI's are simply not the only 'most stable' option, depending on what you are doing. That is all.

Nobody is saying that Pi's are in any way the "best" option. But they hit a sweet spot in terms of price/performance/features.


Well, now you know we are :rofl:

And it's not just the psu themselves that can cause issues. I have had so called "industrial strength" cables which have turned out to be, well, crap. Especially if they have a switch built into the cable.

Once the power is sorted, the Pis run (scientifically speaking) like forever before requiring attention. If you were having stability issues then you had a bad unit (possible) but less likely than bad power, or were using sub standard sd cards. It is that simple.

1 Like