My NR Fs-file-lister folder is undefined

Hi Good Morning Guys, I don't know why my fs-file-lister folder is undefined. cant even detect the folder can someone tell me how to fix it?

Welcome to the forum @f3lixlee

How did you get to that situation?
Did you import a flow?
Was it previously working?
Try refreshing the browser page, forcing a cache clear in the browser (via the browser menus) and finally, if still not going then restart node red and refresh the browser page again.

If still no joy then go into Manage Palette in the menu dropdown and see if the node is listed in the Installed tab. If not then go to the Install tab and install it. Then refresh the browser page.

Do you mean node-red-contrib-fs?

What platform are you using and what versions of node.js and node-red?

If it is my node, I've not looked at it for 2 1/2 years - I'd have to dig into it to see if it still works.

I'm sorry for the late reply.

  1. I'm new in NR so maybe is the node-red-contrib-fs

  2. I'm using HIVEMQ and the version of node.js and node-red is the lastest version

Hi Colin
Good Morning and sorry for the late reply

1.I actually don't know how i get to that situation. I just know after I install the fs-file, first time its work but after that he temporarily say this file didn't installed but when I check is installed
2. Nope I didn't import any flow
3. Yep its working

  1. Yeah I did. I refresh the page forcing a cache clear in the browser and restart nr in my cmd
    then still same as before that

I hope you are not using the latest version of nodejs, which is not recommended, you should be using 14, 16 or 18. Which is it please?

Also saying the latest version of node red does not help. Perhaps what you think is the latest is not. Which version is it please? We need to know that in order to attempt to replicate your problem.

Can you please go to the Node-RED log and include the output from where Node-RED is starting up through to where it says "nodes started" or where you get an error from the node, whichever is later.

Copy the log as text and paste into a reply here between triple back-quotes like so:

   code goes here 

That may help us see what is causing the issue.

My Nodejs version is 19.4.0

Not a good choice. Please only use LTS versions. These are even numbered. The latest LTS version being v18. The odd numbered versions are not considered stable and the very latest unstable version is very likely to have breaking, unstable, changes.

Downgrade to a supported version (16 is the current recommended, but 18 is supported, any problems found with 18 should be fixed). Supported Node versions : Node-RED

If it still doesn't work then post the log as requested above.

k i try it now

k thx colin I will test now

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.