🎉 Node-RED 1.0.0-beta.4 released

We have published the final beta of Node-RED 1.0.

This release sweeps up a number of bug fixes and brings us very close to the final release.

Cloning messages

Following the feedback on the last beta, some more changes were needed to help minimise the impact the move to asynchronous message passing brings.

This release, as I described on the blog last week, changes the default behaviour of the Function node to always clone messages passed to node.send().

If you didn't follow the discussion in the last beta release thread, have a read of the blog post to find out what has changed.

Removed Nodes (again)

We have removed some more nodes from the default palette.

In additional to the other nodes we removed in the last beta, the Sentiment nodes is no longer installed by default. It is now in its own npm module and can be installed separately.

Installing the beta

If you want to try out the beta, you will need specify node-red@next when you use npm to update. Without the @next you'll still get 0.20.x.

So on a Pi you'd do:

sudo npm install -g --unsafe-perm node-red@next

Reporting problems

If you hit any problems, please report them either as a reply on this topic, or in the #dev slack channel. Please do not post new topics to the forum regarding the beta as that could confuse users who are not using the beta.

Outstanding work

We had intended beta.3 to be the final beta before the full release, but we wanted to get the message cloning change into the hands of beta testers - we didn't want to leave that until the final release.

Good progress is being made on the various other things we need in place for the release and we're on track for releasing 1.0 on .... well, lets not spoil that surprise just yet.


Great news! I will update my test installation shortly.

Thank you for your hard work! :grinning:

I still have an issue with node-red-contrib-static-markdown.

The Editor tells me it isn't installed:


The palette manager tells me it kind of is but kind of isn't:

The console tells me it is:

And it is serving things up:


I'm confused. I've tried removing and re-adding it from the command line (when NR isn't running).

I'd contact the author of the node for clarification :wink:

PS - just installed it locally and all fine for me....

I would do but he is a lunatic who likes shouting abuse at me so I do my best to avoid him :nerd_face:

Any other suggestions?

nope - it's working here...

Upgraded to 1.0.0-beta.4 and seeing this.
Using nodes from node-red-contrib-modbus in a PLC-HMI application.
This is the error from the console:

(node:7245) UnhandledPromiseRejectionWarning: TypeError: a is not a function
at activateSending (/home/pi/.node-red/node_modules/node-red-contrib-modbus/modbus/maps/modbus-client.js:577:20)
at process._tickCallback (internal/process/next_tick.js:68:7)

Down-graded to 1.0.0-beta.2 and problem goes away.
Has anyone else seen this issue?

I am running V1.0 beta 4 since yesterday. I thought I had messed up as I can confirm on android 9 I am running node-red ui ok and switching tabs, BUT
+++++++ I cannot get get node-red flow.
I get title Node-red on black background with thw red signature for it with a blank screen

Pete Scargill has similar problem cannot tab when using Android
NR tabs editor don’t work in Android chrome.

On Android 9 flows
So by firefox does not work.
By Chrome does not work

Windows still works with ui and flow on firefox and chrome
All works on windows 7 as normal

Correct - sorry I was on holiday and could not really write much. On my Android tablet - I tried going into the Node-Red editor to update the Alexa code in a function attached to node-red-contrib-alexa-echo. I normally do sush function coding on a PC. In Node-Red I could use the arrows at the top of the screen to switch from tab to tab but could not actually SELECT any of the tabs so I gave up. As I normally work on a PC (and only use NR DASHBOARD on Android) I had no idea if this was a new problem or not.

@elch @scargill - Yes, it's an outstanding problem for which Nick is aware of.

It appears that there is no touch handling code (or it's not working as it should).
The work around is a but fiddly though -
Tap the tab that you want to select, then immediately drag it to one side - just a little bit, and release.
You should find the focus will then move to that tab.

I got caught out with that when I was also away from home, and needed to make a flow change.

Hey thanks for that – would a usb mouse do the job until they fix it?

I assume so because it's the 'touch' handler that's not working.

Although not a great solution, the 'touch, drag, release' work-around does work, and once that you have selected the tab, most other edit functions do work to enable the flow to be edited.

hello Paul-Reed

Thanks for the quick answer will try your temp soloution

regards elch

I just ran into what is seemingly a bug with the "Complete" node.

When I exported a flow containing a "Complete" node, and imported it to another Pi also running v1.0.0b4, the link between the "Complete" node and the node it was watching was broken and had to be re-established.

I was able to replicate the issue multiple times.

Good spot - thanks for reporting. Now fixed in git.

Wow, thanks for the quick work!

One other thought on this... for the "Complete", "Status" & "Catch" nodes, it would be really handy if they had the same "invisible" connection lines like the "Link" nodes show.


Yup, that thought has occurred to us. It's a post-1.0 thought though. The link nodes are handled as a special case in the view code - it needs to be refactored to make it easier for other node types to be able to make use of it.


needs lots of thinking through though... (so as Nick says not until after 1.0)... such as where on other nodes would it connect to - as lots of them don't have output connectors and some do... so would a virtual connector be added or ... etc.. not going to think about it now.

I tried Node-RED v1.0.0-beta.4 on Internet Explorer 11 on Windows 10. I found that "Selection to subflow" doesn't work correctly. For example, after converting the template node to subflow, the subflow newly emerges but the template node still remains on the workspace. (As we know, the template node needs to be removed because the subflow node contains the template node.) After this operation, some nodes cannot connect to other nodes.


Additionally, I found that there're other non-critical problems as follows.

(1) The logo name is just "Node-".
(2) Node icons don't appear in the workplace.
(3) Icon size in typedInput is too large.

I think that BrowserStack is useful to check UI on multi-browsers...(Safari from Windows or Internet Explorer from Mac)

1 Like

@knolleary on iOS (13) the node-red editor does not load, is this a bug ?