🎉 Node-RED 1.3.1 released

Node-RED 1.3.1 is now available.

Thanks to everyone who tested the beta and provided feedback.

Full details of the release on the blog:

20 Likes

Awesome!

The function node more and more weakens the need for creating a custom node.
I wonder if at some point it makes sense to have editor widgets like a simple checkbox or an input field configurable on the setup tab of the function node....

1 Like

Hey i just had a chance to read the details and i’m amazed by how node-red is improving day by day! Huge thanks to all who contributed to the release!

1 Like

Remember that many users are not fluent in programming. I am happy to see plugin system. Export view also looks cool!

This is very cool to see, and also very nice of you @dceejay to have updated this too for 1.3:

Looking forward to see how well this npm integration works in function nodes.

Thanks everyone!!!

1 Like

note - the electron build is just a starter project - we (I) do not test in other than to check it builds and runs as is - Things like npm / projects / binary nodes may well need extra work to make work correctly - especially on other platforms. (And Pull requests to fix things gratefully accepted of course :slight_smile: )

2 Likes

Guys, awesome stuff.

I have just upgraded trivslly (the truly gret benefit of docker)

9 Apr 07:51:04 - [info] Node-RED version: v1.3.1
9 Apr 07:51:04 - [info] Node.js  version: v10.24.1
9 Apr 07:51:04 - [info] Linux 5.4.0-70-generic x64 LE
9 Apr 07:51:04 - [info] Loading palette nodes
9 Apr 07:51:05 - [info] Settings file  : /data/settings.js
9 Apr 07:51:05 - [info] Context store  : 'default' [module=memory]
9 Apr 07:51:05 - [info] User directory : /data
9 Apr 07:51:05 - [warn] Projects disabled : editorTheme.projects.enabled=false
9 Apr 07:51:05 - [info] Flows file     : /data/flows.json
9 Apr 07:51:05 - [info] Server now running at http://127.0.0.1:1880/
9 Apr 07:51:05 - [warn] 

and have set

 functionExternalModules : true,

/data/settings.js

however I dont see the modules section in the function set up page

I must have done something silly but cant see it

Thanks

This is the story of my life lol

Have you restarted node-red after editing settings.js?
Could you do a hard refresh of browser?
Could you check browser console for any oddities?

I think I seen something on this recently (for the beta) but cant for the life of me find the post.

1 Like

Steve,

thanks - closed the safari tabs and reloaded and all good. Slightly embarrassed :blush:

1 Like

So I'm attempting a fresh setup with the Electron build and node-red 1.3:
I set functionExternalModules as true as needed in settings.
Ran via yarn start but I can't get the Setup tab in a Function node to reveal the Modules fields as expected for npm support.
I'm running on windows 10, yarn version 1.22.5, node version 14.5.1

EDIT:
I hit Ctrl + Shift + I to open console while on the Editor.
then put in console: RED.settings.functionExternalModules which returned false

So then i set it true manually with: RED.settings.functionExternalModules=true
reopened the test function node, and I could see the Modules field(s).

And as I suspected this poses issues with actually using npm as I'm getting errors when attempting to use it ("Error: Function node not allowed to load external modules")
... so I'll wait for a reply before attempting to go further with npm integration/support testing)

Not sure where I should go from here but I'd appreciate any help.

Really liking the new 'function node' features, especially being able to add external modules for use in the node :+1:
I've just tried using a few packages, and found it very easy to use, and has opened up a whole lot of new opportunities for me :grin:

I assume that removal of unused modules within externalModules is something that may be developed in the future, and until then we need to manually edit the externalModules package.json to remove the reference, delete the package, and restart node-RED.

1 Like

OK, I'm a dummy. My "upgrade", using the debian buster script gave no errors but when I type "node-red-start", I get the following:

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

Running Node-RED install for user pi at /home/pi on raspbian


This can take 20-30 minutes on the slower Pi versions - please wait.

  Stop Node-RED                       ✔
  Remove old version of Node-RED      ✔
  Remove old version of Node.js       -
  Leave existing Node.js              -   Node v12.22.1   Npm 6.14.12
  Clean npm cache                     -
  Install Node-RED core               ✔   
  Move global nodes to local          -
  Install extra Pi nodes              ✔
  Npm rebuild existing nodes          -
  Add shortcut commands               ✔
  Update systemd script               ✔
                                      

Any errors will be logged to   /var/log/nodered-install.log
All done.
  You can now start Node-RED with the command  node-red-start
  or using the icon under   Menu / Programming / Node-RED
  Then point your browser to localhost:1880 or http://{your_pi_ip-address}:1880

Started  Fri 09 Apr 2021 03:02:56 PM CDT  -  Finished  Fri 09 Apr 2021 03:03:53 PM CDT

pi@pigate:~ $ node-red-start

Node-RED is not yet fully installed. Please re-run the install script again manually.
 
   bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)
 
then retry  node-red-start

Tried the upgrade script first (fail), then ran sudo apt update && sudo apt full-upgrade as Colin suggested in the 1.31 SQlite thread, then reran the script. Same thing.

What next?

Russ

Have you looked at the install log? it provides more detail.
/var/log/nodered-install.log

Are node.js and npm the version reported ? What does node -v && npm -v report ?
Which version Pi is this on ?

In particular have you possibly previously installed nvm (Node Version Manager, I think)? There are node-red tutorials out there that suggest that, and it messes up the install script.

Apologies, I had other more pressing matters to attend to so I reloaded yesterday's (good) imagefile so I could get N-R back up.

I did look at the log but (as a rookie) couldn't make sense of it. I also tried to install the new version using the npm command and got something about broken dependencies.

I do remember the node.js and npm versions not being changed by the script, njs was 12.20x and npm was 6.14x.

Any words of wisdom on trying this upgrade again later?

Thanks!

Russ

What do these show?
node -v
npm -v
which node

Did you see the question asking if you have previously installed nvm?

In your circumstance as you are on a decent level of nodejs you could just run sudo npm i -g --unsafe-perm node-red@1.3.1 then restart it.

Colin, I had to do a DDG search for "nvm" as I had no idea what it even was. Now that I see what it is, it's not installed on my pi.

My non-upgraded previous system shows:
root@pigate:/home/pi# node -v v12.20.0
root@pigate:/home/pi# npm -v 6.14.8
root@pigate:/home/pi# which node /usr/bin/node

dceejay, I'll try your suggestion later and see what it does.

Thanks!

Russ