Node Red access to USB port for rfxcom (running in iobroker)

My Node Red runs in iobroker, on Windows10 Pro. I want to give Node Red access to one (or all) of my USB ports, to access my Rfxtrx 433 device (it is on USB4)
I am trying to use the Rfxcom nodes, but trying to configure the device it does not look as if I have access to the USB ports on my machine. I guess I need to configure that in iobroker, but dont know how
I have a rfx sensor node, and configured the serial port as /dev/ttyUSB4, but it just says disconnected under the rfx sensor node (I have tried anything from USB0 to 4). I have attached a debug to the sensor node (show complete message) but nothing is showing in the debug window

That is not a Windows USB port. They are things like COM3:.

To see available COM ports, open "device manager", turn on "show hidden" and they should show up as "Ports (COM & LPT)"

It is on USB4. I checked in the device manager on the events, which shows

Device FTDIBUS\VID_0403+PID_6001+A1Y17NPPA\0000 was configured.

Driver Name: oem19.inf
Class Guid: {4d36e978-e325-11ce-bfc1-08002be10318}
Driver Date: 08/16/2017
Driver Version:
Driver Provider: FTDI
Driver Section: FtdiPort.NTamd64
Driver Rank: 0xFF0000
Matching Device Id: FTDIBUS\COMPORT&VID_0403&PID_6001
Outranked Drivers:
Device Updated: false
Parent Device: USB\VID_0403&PID_6001\A1Y17NPP
Com port

So the serial port you need to use in Windows is COM4:

Yes I tried that, its not connecting

Possibly the port needs a specific configuration - you would need to check the devices documentation for that. Or possibly ioBroker is getting in the way, I don't use it so I can't help there.

I would usually stop node-red and use a command line tool to connect to the serial port to make sure it is talking and that I know what settings to use.

Also check and make sure nothing else has grabbed the port. Typically only one app/service can connect to a serial port at one time.

You could also delete the rfx node and use a standard serial node to see if you can get any data out.

1 Like

That was it. My Homeseer system was still using the USB port to read data from the Rfxtrx. After I turned it off, data started flowing !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.