Node-red-contribi2c (SHT31)

Hi! I have a problem with i2C-scan with node-red.
My Flow just uses i2c Scan and node debug.
A SHT31 (temperature and humidity) is connected on Raspberry pi 4. It is detected with the console and the command i2cdetect -y 1. Adress 0x44.

But in node-red, i have a message: "Error: Invalid I2C bus number false"
I have tested with another card i2c but it is the same problem.
I2c is activate too.

I have tested with a program wrote in Python. (import smbus) that work very good.
In node-red (node exec ), it is the same, very good.

I don't know what is the problem. Thank you for your help please!
Jean-Michel

1 Like

Hello,

i have the same Problem. My Node-Red installation is on an RPi3 and all was fine. Today i made an update to the installed nodes an now i have the same error message. i2cdetect gives me all Adresses on the Bus.
So i used a new SD-Card and made a fresh install. Only with this node. Same result. "Error: Invalid I2C bus number false"

So i think my old installation is still ok but i dont how i can find the problem.
Jörg

same problem here.

msg : error

"Error: Invalid I2C bus number false"

You can install the previous version for the moment by going to your .node-red folder and running
npm install node-red-contrib-i2c@0.7.3
assuming that the previous version was 0.7.3. Then restart node-red.

I see an issue has been raised so it will likely get fixed fairly quickly, then you can upgrade again. https://github.com/nielsnl68/node-red-contrib-i2c/issues/37

version 0.7.5 published

1 Like

Thanks a lot. I am going to test immediatly.

It works very nice. Thank you.

1 Like

Very Gooood!!! Thank you!!!

1 Like

Phew ! - thanks for the quick feedback.

I said it would likely get fixed fairly quickly, but 3 minutes is beyond normal expectations of 'fairly quickly'. :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.