Node-Red crashed... :-(

Hallo everybody,

at first i have to say sorry about my english... I'm not very good, but i trie my best :slight_smile:

I'm new in the world of Node-Red and also in Raspberry so i have to ask you a question...

I've bought a "Ready to run" Raspberry Pi for the DIN-Rail.
The pi was ready installed and the Node-Red is also installed yet.

I tried my first projects and started witch the first experience in KNX-Connections.
This worked great.

Now i added a Alexa Node and tried several Options. Then the whole Node-Red was off.

When i start the Node-Red in the Pi console (per SSH), there is an error by connecting to the lokal IP and Port 80 - Permission denied.

Now my question: Is it possible to disable a flow bei SSH console?
Where are the flows saved?

Or is it posible to delete a whole Flow?
Or is it possible to start Node-Red in a "save-Mode" ??

Thanks for your answers!

Greetings Frank from Germany...

You can indeed start node-red in safe mode on your ssh terminal

node-red --safe

When started in safe mode you can edit your flows and/or remove the bad ones.

  1. what model Pi do you have? If you SSH ito the pi, run this command:
    cat /proc/device-tree/model
  2. what version of NR are you running? (you can get this from the startup log)
  3. what OS is running? Run this command:
    cat /etc/os-release
  4. Starting NR in safe mode depends on the version of NR you are running. It was introduced with version 3
    Node-red is installed in a hidden folder in the home directory of the Pi user. You can get to it by using the command
    cd $HOME/.node-red
    Depending on the release of NR, the flow file will be flow.json or it could be the name of the Pi.flow

Hallo, thanks a lot!

the start witch --safe was that i searched for.

I started, deleted the node with the error and deployed the flow.
Now everything is fine!

Thank you

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.