Node Red Dashboard not appear in different port

  1. What do you see in the browser when you try to view the dashboard?
  2. Does the editor work ok on that port?
  3. Open the Developer Console in your browser and refresh the page and see if any errors shown.
  4. Please stop node red and start it again in a terminal and copy/paste the output you get here.

Hello thanks Colin for the reply

my console is look like this

and my dashboard appear like this


it should be appear UI table widget

and my flow editor still working but dashboard not appear also for another group of dashboard

Any idea or suggestion?
Regards

The log says that you have error in some function. Search where it is and fix it first.
(don't know about the other tabs, but in this tab the function without name I'd suspect)

Also you are using an obsolete and unsupported (by node red) version of nodejs (13.14.0). It may not be the cause of the problem but you should use either 12.x or 14.x.

In future please copy/paste logs rather than screenshot if possible.

Hello HotNipi,

the error of the function because of initial for global variable (global.get("waktu") is undefind value) .its ok for my flow,because when i tried import in port 1880 in the same pc its working. and the other of group dasboard appear

this my console for port 1880 without node red port 1881

gambar

and the dashboard like this

for the dashboard of port 1881 is

and when i tried make a new group is not appear too. i think its stuck

ok now i tried to uninstal this , and instal nodejs (14.15.1 -64bit) and try again

thanks

Having done that you need to re-install node-red and also go into each .node red folder and run
npm rebuild

In future please copy/paste logs rather than screenshot if possible.

If that doesn't fix it then stop the node red that is running on the default port and run the one that fails, with and without the port specified. That will prove it is the port that is the problem.

[Edit] If still not working then do what I asked in the first post:

Hi Collin

i already instal nodejs 14.15.1 and export my project in port 1881 and npm rebuild .
but the result is the same
and about developer console in my browser

XHRPOSThttp://localhost:1881/ui/socket.io/?EIO=3&transport=polling&t=NTyhYRs&sid=GiB6pvjBLhSdSU3AAAAB
[HTTP/1.1 400 Bad Request 33ms]

You are using the ngTouch module.
AngularJS Material already has mobile click, tap, and swipe support...
ngTouch is not supported with AngularJS Material! app.min.js:150:202
XHRGEThttp://localhost:1881/ui/loading.html
[HTTP/1.1 404 Not Found 31ms]

Rendered http://localhost:1881/ui/css/app.min.less successfully. app.min.js:533:12831
CSS for http://localhost:1881/ui/css/app.min.less generated in 1165ms app.min.js:533:12831
Less has finished. CSS generated in 1169ms app.min.js:533:12831
GETws://localhost:1881/ui/socket.io/?EIO=3&transport=websocket&sid=yfcG4UkQ9_k9UJlxAAAC
[HTTP/1.1 400 Bad Request 6ms]

Firefox can’t establish a connection to the server at ws://localhost:1881/ui/socket.io/?EIO=3&transport=websocket&sid=yfcG4UkQ9_k9UJlxAAAC. socket.io.js:8:5939
Source map error: Error: request failed with status 404
Resource URL: http://localhost:1881/ui/js/app.min.js
Source Map URL: angular-chart.min.js.map

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help http://xhr.spec.whatwg.org/

is this what you mean?

so what i have to do now?

thanks

Did you try that? Stop the instance of node red running on the default port then start the failing one, using the same command line each time, but first on the default port then stop it, then try on the other port.

i did tried it but the result is the same..
and now i realize when i import my flow one by one, a few dasboard appear normaly and when i tried import flow with UI-table widget my dashboard become error again, also when i add new UI-table

is there any widget component can i use to replace UI-table ?

Have you installed the latest version of node-red-node-ui-table?

Edit: Also if you simply add a ui-table to the flow does it mess it up or is it something to do with the flow you are importing?

yes i instaled latest version 0.3.10 (2 month ago)

if i add fresh new ui table its working only for ui table, but the other widget not show ..
now i still working on it and i got this msg
""*** Order property not set. Please contact developer. ***" on debug window when i tried deploy my flow.
edit : this msg appear because i import example of ui-table (simple table)

but on port 1880 everything is normal

What other widget and where do they not show?

Please confirm that you have tried running the same flows file with and without the port specified. So use exactly the same command line on the same system with and without -p 1881

i run node-red reffer to Steve-MCL on Node red multiple instances

node-red -p 1881 -u c:/node-red-1881

sorry maybe i can explain with a screen shoot

this is i make new fresh node on node-red -p 1881 -u c:/node-red-1881
and i tried import UI-table example Richer Table and add my own button on the same UI-Group

when i deploy the node and open localhost:1881/ui . the button is disappear

[{"id":"8b05248b.9b007","type":"tab","label":"Flow 1","disabled":false,"info":""},{"id":"b7dff285.69049","type":"inject","z":"8b05248b.9b007","name":"","repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"[{"Name":"Yokoi","Age":"30","Color":"lime","Prog":70,"Star":"3"},{"Name":"DCJ","Age":"50","Color":"dodgerblue","Prog":"45","Star":2,"Pass":false,"web":""},{"Name":"Nick","Age":"40","Color":"darkred","Prog":95,"Star":"5","Pass":true,"web":"http://nodered.org"},{"Name":"Oli"}]","payloadType":"json","x":290,"y":80,"wires":[["7d48e13.90ee22"]]},{"id":"cb53cb76.5fd0d8","type":"inject","z":"8b05248b.9b007","name":"","repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"[{"Name":"Yokoi","Age":"30","Color":"lime","Prog":20,"Star":"1"},{"Name":"DCJ","Age":"50","Color":"dodgerblue","Prog":"80","Star":4,"Pass":true,"web":""},{"Name":"Nick","Age":"40","Color":"red","Prog":90,"Star":"5","Pass":true,"web":"http://nodered.org"},{"Name":"Oli"}]","payloadType":"json","x":290,"y":120,"wires":[["7d48e13.90ee22"]]},{"id":"7d48e13.90ee22","type":"ui_table","z":"8b05248b.9b007","group":"571a38b1.5e3638","name":"People","order":1,"width":"8","height":"3","columns":[{"field":"Name","title":"Who","width":"","align":"left","formatter":"html","formatterParams":{"target":"_blank"}},{"field":"Age","title":"Age","width":"40","align":"center","formatter":"plaintext","formatterParams":{"target":"_blank"}},{"field":"Color","title":"","width":"5%","align":"left","formatter":"color","formatterParams":{"target":"_blank"}},{"field":"Star","title":"%","width":"100","align":"left","formatter":"star","formatterParams":{"target":"_blank"}},{"field":"Pass","title":"","width":"5%","align":"center","formatter":"tickCross","formatterParams":{"target":"_blank"}},{"field":"Prog","title":"","width":"80","align":"left","formatter":"progress","formatterParams":{"target":"_blank"}},{"field":"web","title":"URL","width":"","align":"left","formatter":"link","formatterParams":{"target":"_blank"}}],"outputs":0,"x":500,"y":80,"wires":},{"id":"16a731c.19d9a4e","type":"ui_button","z":"8b05248b.9b007","name":"","group":"571a38b1.5e3638","order":1,"width":0,"height":0,"passthru":false,"label":"button","tooltip":"","color":"","bgcolor":"","icon":"","payload":"","payloadType":"str","topic":"","x":490,"y":140,"wires":[]},{"id":"571a38b1.5e3638","type":"ui_group","name":"Richer Table","tab":"29ec6908.552b36","order":1,"disp":true,"width":"8","collapse":false},{"id":"29ec6908.552b36","type":"ui_tab","name":"Home","icon":"track_changes","order":1,"disabled":false,"hidden":false}]

i just look different on my command prompt when i run on port 1880 and 1881

node-red -p 1880 -u c:/node-red-1880

Welcome to Node-RED

8 Feb 10:50:47 - [info] Node-RED version: v1.2.9
8 Feb 10:50:47 - [info] Node.js version: v14.15.1
8 Feb 10:50:47 - [info] Windows_NT 10.0.17763 x64 LE
8 Feb 10:50:51 - [info] Loading palette nodes
8 Feb 10:50:58 - [info] Dashboard version 2.27.0 started at /ui
8 Feb 10:50:58 - [info] Settings file : c:\node-red-1880\settings.js
8 Feb 10:50:59 - [info] Context store : 'default' [module=memory]
8 Feb 10:50:59 - [info] User directory : c:\node-red-1880
8 Feb 10:50:59 - [warn] Projects disabled : editorTheme.projects.enabled=false
8 Feb 10:50:59 - [info] Flows file : c:\node-red-1880\flows_HOME-PC.json
8 Feb 10:50:59 - [info] Server now running at http://127.0.0.1:1880/
8 Feb 10:50:59 - [warn]


Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

8 Feb 10:50:59 - [info] Starting flows
8 Feb 10:50:59 - [info] Started flows

node-red -p 1881 -u c:/node-red-1881

Welcome to Node-RED

8 Feb 11:06:52 - [info] Node-RED version: v1.2.9
8 Feb 11:06:52 - [info] Node.js version: v14.15.1
8 Feb 11:06:52 - [info] Windows_NT 10.0.17763 x64 LE
8 Feb 11:06:54 - [info] Loading palette nodes
8 Feb 11:06:58 - [info] Dashboard version 2.27.0 started at /ui
8 Feb 11:06:58 - [info] Settings file : c:\node-red-1881\settings.js
8 Feb 11:06:58 - [info] Context store : 'default' [module=memory]
8 Feb 11:06:58 - [info] User directory : c:\node-red-1881
8 Feb 11:06:58 - [warn] Projects disabled : editorTheme.projects.enabled=false
8 Feb 11:06:58 - [info] Flows file : c:\node-red-1881\flows_HOME-PC.json
8 Feb 11:06:59 - [info] Server now running at http://127.0.0.1:1881/
8 Feb 11:06:59 - [warn]


Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

8 Feb 11:06:59 - [info] Starting flows
8 Feb 11:06:59 - [info] Dashboard version 2.27.0 started at /ui
8 Feb 11:06:59 - [info] Started flows

is there connection with this? or i need to modified my settings.js?

Please always show the command you have used to start node-red when you post logs, otherwise it is impossible to know what is happening. I don't know what you think is not right about the logs you have posted, though you have not only asked for a different port, but have also specified a different user directory.

Perhaps there is a language problem, but I still don't think you have done what I have asked. You think there is a problem caused by the port number, to prove that you must run exactly the same command except for the -p option.

ok colin thanks for support and advice.

maybe i pending it right now.and use port 1880

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.