Node-red error, I can't open node red anymore

Hello, I was testing the "firestore-cloud" node and my local node-red crashed with the following message in the log:

12 Mar 12:35:01 - [info] Starting flows
12 Mar 12:35:03 - [info] Started flows
12 Mar 12:35:03 - [red] Uncaught Exception:
12 Mar 12:35:03 - UnhandledPromiseRejection: This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). The promise rejected with the reason "Cannot set document ref in a collection group query".

I can't open node-red anymore, do you know what I should do?


Have you tried starting node-red in safe mode? You can run it by starting node-red as node-red --safe. That will only start the editor, but not start the flow itself. You can use it to fix any flows that crash the install, then deploy to restart the flows without the crash that occurred being repeated.

It worked, afelix. Thank you!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.