Node-Red Freezes

I am trying to use an “ina-sensor” node to read the volts/amps from an INA219 sensor from ada-fruit. This sensor works on the I2C bus. When I add the sensor, my Node-Red fails after a few hours.

I re-booted the Raspberry Pi 4 and started Node-Red from the console. Following text is what I see on the console, the last trhee lines keep repeating up to the Node-Red freezing. When I remove the INA219 Sensors from the circuit, I no longer get the repeating lines:


Start Node-RED

Once Node-RED has started, point a browser at
On Pi Node-RED works better with the Firefox or Chrome browser

Use node-red-stop to stop Node-RED
Use node-red-start to start Node-RED again
Use node-red-log to view the recent log output
Use sudo systemctl enable nodered.service to autostart Node-RED at every boot
Use sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to

Starting as a systemd service.


I have tried every everything to isolate the problem. New Raspian load, new Node-Red load, new SD Card, new Raspberry Pi.

I also tried four separate INA219 boards. I tried changing the address of the board, some with 0X40 and some with 0X41. I get the same result.

I have reduced to flow to two nodes, a “ina-sensor” node and a “debug” node. No other nodes are running.

I need any help or suggestions. Clearly, something is causing the repeating lines, “false”, "initing" and “0.01” that leads up the Node-Red freezing up.


Perhaps raise an issue on the GitHub repo


When you say you tried everything, did you try different nodejs versions? What version are you running? Perhaps that node doesn't like particular versions?


No, I did not try other nodejs versions.

Where do I get my nodejs version? Can you point me to something to read on how do change the nodejs?


I did run the install script from the web site for the Raspberry Pi.

The Web site says the script will:

So, I assume I have Node 8.


In a terminal, type node -v followed by enter key

I would personally install V10 or 12

I have. v10.16.3

How do I install V12?

OK, I found several articles on how to update NodeJS.

How should I proceeded to match the "ina-sensor" node with the correct NodeJS version?


No idea, was just a suggestion. My guess, from the date on the last published update, V12 was out. As you're having no success with several different hardware, try something else.

Well, I found the problem.

After trying all combinations of operating systems, Node-Red and node.js, none fixed the problem of Node-Red freezing up after about an hour.

So, I pulled the Raspberry board and the INA-219 board and built it up on my bench using a breadboard. It worked just fine!

I put the Raspberry board and the INA-219 board back into my cabinet, and again, after about and hour, Node-Red froze up again.

Th "failure" hardware configuration includes a common , 10 foot length of RJ50 cable for both the I2C bus devices (INA-219) and the One Wire devices (Temperature). I found these two data buses could not "co-exist" on the same ten foot length of cable.

I ran each data bus on separate cables and.....problem solved!


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.