Node Red iiot OPCua No Injector Node

Hi folks, I am a little new to Node Red but have been getting up to speed.
I have an application I have test on my Windows 10 Laptop using a KepWare Server and the iiot OPCua Pallet. I loaded the newest version of Node JS and the latest version of Node Red.
I can build the flow and it works fine on my laptop. I can read values for an OPC ua server.

The machine I am testing with is a Windows 7 desktop PC. I installated of Node JS and Node Red goes OK and installs properly. Then I install the iiot OPC ua Pallets.

npm install node-red-contrib-iiot-opcua

That installs fine. Once I import the flow the Injector Node loses it Properties.
I then place a new iiot OPCua Injector in the flow and it shows up Blank?

I then Uninstalled Node-Red and deleted the .Node-Red directory.
I reloaded Node Red and tried to install an older version of the iiot OPCua pallets using

npm install node-red-contrib-iiot-opcua@2.7.1

I am still missing the properties for the injector node and there is no text on the node like the other iiot OPCua node I can drop in the flow?

Not sure what I an doing incorrectly?

Thanks,

As per the docs, the recommended version of nodejs is the LTS version. Which is also the version that the nodes readme says it is tested against. I would suggest trying with that and if you still have an problem, open an issue on the nodes github page.

Appreciate the help, I'll give it a try,
Thank You!

I use the iiot-opcua with node V10 LTS & it works ok. Never tried with V12. Try rolling back nodejs to v10.

I'm using nodejs LTS ver. but i have same problem like that

You haven’t ever said what version of Node-RED you are using.

The readme says it is tested against v0.20.x

Thank you for your help!
And also sorry about opening the same issue post. This is my first time joining the forum. I have no idea how to use well. (i'm gonna read ' community guidlines', Sorry)

Thank you

What version of node red? Look in the start up console messages or the menu of node-red (top right hand hamburger menu)