Node-red No debug output (WAGO PFC & ecockpit)

Hello, i am trying to create a simple program where node-red receives UDP messages from software called ecockpit which creates UDP network sender variables. I am trying to see that variable on the node-red flows by using netvar receiver. However i don't have anything on my output. when i worked with previous version of node red (rpi-v8) it worked fine in terms of communicating on 1202 port via UDP however this version does not. Currently i am using node-red:2.2.2 version. Please see attached image of flow i created.

Please help

I notice you are running under docker... have you enabled the correct ports for the container (where node-red is running) to be able to see your host network ?

1 Like

do you really need to use docker ? for low level networking things it often gets in the way (as indeed it is supposed to do :-)...

But you probably need to add some more -p 1234:1234/udp like statements to your docker command to let port 1234 (in this case) into and out of the container. Note that only tends to work for direct udp connections - if you are using broadcast or multicast you may need something more.

Hello thank you for your response. So if i want to access node-red on 1880 port from my local device and the software is sending UDP messages on 1202 port (default port for the software) , is this how the command line should be? i might be running loopback or i am thinking it wrong?

docker run -it -p 1880:1202 -v node_red_data:/data --name mynodered nodered/node-red:2.2.2

Would you mind little bit more detailed about the command line? 

Thank you

no - you need -p 1880:1880 to allow the web browser port through (on tcp the default) - - you need to add another -p 1202:1202/udp to allow udp port 1202 through as well so.\

docker run -it -p 1880:1880 -p 1202:1202/udp   -v node_red_data:/data --name mynodered nodered/node-red:2.2.2
1 Like

Thank you very much! that worked, i never knew that problem was towards my docker command line. i tried using a netstat -a or a wireshark to see if there is any realtime UDP transactions or not but yeah seems like that was definitely not the right approach at all! Thank you again and please do share any future tips for troubleshooting in these kinda problems.

Thanks

Well if you use docker then reading the docker command line manuals is always a good idea!

1 Like

Hello, thanks for helping on the setting up of a direct UDP connection on the node-red via docker. I am actually stuck where i am sending (UDP output) in this case via netvar-sender node in the node-red. I don't get any data out from UDP out as i believe you mentioned above that for the broadcast or multicast i require something more, can you please guide me, more on that?