Node-red-node-sensortag not working on Mac OS 10.14.4

#1

Hello,

After multiple attempts, I'm turning towards you... I'm trying to use my TI sensortag on Node-Red but it keeps hanging on "discovering..."

My sensortag is up and the info on it (physical sticker) is:
1.7.2.8
BLE
Rsv 1.5.0
Rsv 1.4.2

Using Mac OS 10.14.4
Node-RED version: v0.20.3
Node.js version: v11.12.0

Please tell me what information you need to understand my issue! :wink:
(screen capture, logs, etc..)
Many thanks

0 Likes

#2

try using the recommended version of nodejs LTS which is v10.

0 Likes

#3

Thank you very much, now using the following but same issue still...

[info] Node-RED version: v0.20.3
[info] Node.js version: v10.15.3

(Changed Node version, rebuilt node-red-node-sensortag as it was compiled against node v11, relaunched node-red and redeployed)

0 Likes

#4

did you read the prereq's?

Pre-requisites

You will need a suitable Bluetooth Low Energy (BLE) stack and drivers for your hardware

  • for example Bluez 5.2.x or better.
0 Likes

#5

I did read pre-requisites and checked my macbook's bluetooth stack was compatible.
However, I tried to find another compatible BLE stack but was unable to find one... if you could point smth at me on this one :wink:
Thanks

0 Likes

#6

Sorry, I've never used it, I just wanted to make sure you had done the prerequisites

Have you tried node-red-piervin-sensortag?

0 Likes

#7

Thanks for the hand! :wink:

I have tried but unfortunately falling on this error when launching node-red:
[node-red-piervin-sensortag/sensorTagWithBattery] Error: Cannot find module './build/Release/binding.node'

I have searched for a fix and somehow node-gyp compilation is failing. I thing I should use latest version of node modules instead of the ones specified. (edit package.json)
I'll try that tomorrow...

Anyone has ideas for the standard node ? (should I open an issue on Github? [probably too early])

0 Likes

#8

looking at the compile errors I suspect you may need to drop back to node 8.x (if you are lucky).

0 Likes