Node-red project: Cannot pull from remote when repository is private

Hello,

I recently started to use Node-red projects in order to have version control of my projects, and especially to be able to have my code in GitHub.

For now, I had no problems with pushing to a GitHub repository.

However, I just modified my readme on GitHub, and I wanted to pull my changes to Node-red, which didn't work. Here is how my projects tab looks like:

Every time I click on the pull button, nothing seems to be happening, but when I check in the console, I get an error.

Is this a known issue? Could it be a configuration problem?

Thanks in advance for your help!

Hi @opatiny

That is odd - you've hit the "should never happen" level of error reporting in the editor.... which isn't ideal.

Can you check the Node-RED logs to see if there's a corresponding error in there?

Hmm, this sounds bad...

I just tried to pull from the command line and it worked perfectly.

I checked the logs and here is the error message:

I forgot to tell you that it is a private repository that I am currently working on.

Don't know if it might have any impact.

Ok, I just tested and pulling works for one of my repositories which is public.

That is interesting. I hadn't tested with a GitHub private repo as I didn't have access to any at the time.

How are you authenticating? HTTPS or SSH keys?

I am using SSH.

Thanks - I think that's enough info to try to recreate it locally, but that's going to take a bit of time. Not going to have a quick answer for you on this. Thanks for reporting. As you've already discovered, you will be able to resort to the command-line for the time being.

That's alright, thank you for your help!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.