Node Red starts very slow and Dashboard losts connection

i installed two ds18b20 sensors on my raspberry pi. I startet with one sensor about 2 weeks ago and created a node red flow so i have the temperature on my dashboard. But since today when i start node red with "sudo node-red" i go to the browser and node red is loading very very long. When it is loaded sucsessfully I go to the dashboard and then there is a red warning "connection lost" in the right corner. Please help me!

Why are you using sudo?

I have no idea but it worked fine until today.

Well there’s no real need to use sudo

When you start Node-RED it displays log messages. please copy and paste those here

Sorry, but it`is in german

pi@raspberrypi:~ $ sudo node-red
31 Aug 14:52:48 - [info]

Willkommen bei Node-RED!

31 Aug 14:52:48 - [info] Node-RED Version: v0.20.7
31 Aug 14:52:48 - [info] Node.js Version: v10.15.2
31 Aug 14:52:48 - [info] Linux 4.19.58-v7+ arm LE
31 Aug 14:52:55 - [info] Paletten-Nodes werden geladen
31 Aug 14:53:05 - [info] Dashboard version 2.15.5 started at /ui
31 Aug 14:53:08 - [info] Einstellungsdatei: /root/.node-red/settings.js
31 Aug 14:53:08 - [info] Kontextspeicher: 'default' [ module=memory]
31 Aug 14:53:08 - [info] Benutzerverzeichnis: /root/.node-red
31 Aug 14:53:08 - [warn] Projekte inaktiviert: editorTheme.projects.enabled=false
31 Aug 14:53:08 - [info] Flow-Datei: /root/.node-red/flows_raspberrypi.json
31 Aug 14:53:08 - [warn]

Die Datei mit den Datenflowberechtigungsnachweisen wird mit einem vom System generierten SchlĂĽssel verschlĂĽsselt.

Wenn der vom System generierte SchlĂĽssel aus irgendeinem Grund verloren geht, werden Ihre Berechtigungsnachweise
Die Datei kann nicht wiederhergestellt werden. Sie müssen sie löschen und erneut eingeben.
Ihre Berechtigungsnachweise.

Sie sollten Ihren eigenen SchlĂĽssel mit Hilfe der Option 'credentialSecret' in
Ihre Einstellungsdatei. Node-RED wird dann Ihre Berechtigungsnachweise erneut verschlĂĽsseln.
Datei mit dem ausgewählten Schlüssel beim nächsten Deployen einer Änderung verwenden.

31 Aug 14:53:08 - [info] Flows starten
31 Aug 14:53:08 - [info] Flows gestartet
31 Aug 14:53:08 - [info] Server wird jetzt auf ausgefĂĽhrt

Have you got a chart on the dashboard? If so then what is the time range of the chart and how often are you sending new values?

Yes i have a chart. And i get every second a new value.

Every second?

And how many seconds of data are you displaying?

what do you mean with displaying?
And is the data recordet?
So you think that it works when i adjust it to every 10 seconds?

In the settings for the chart you setup a time range (or number of points). If you have specified a range then work out how many seconds there are in that range. That will tell you how many points have to be shuffled down every time a new point is added. If you have multiple lines that has to be done for each line. So what is the total number of points are there on the chart? If it is more than a few hundred then it is pointless as there are only a certain number of pixels across the chart.

Nice! I have an intervall of 10 secs and it works. But my next problem is that i dont know how i get two different temperature gauges. I have the rpi-ds18b20 in my nodes but i dont know how to get two different gauges in my dashboard!

Add two gauge nodes and feed one from one sensor and the other from the other sensor.

1 Like

and what is with the timestamp?
And do you mean that i take the ds18b20 two times?

Sorry, I don't understand. A gauge doesn't need a timestamp.
What node type are you using to read the sensors? node-red-contrib-something probably.

Please don’t have two threads for the same problem (how to add two sensors). It just wastes people’s time

After having this problem I unchecked the array checkbox in the DS18B20 node and it resolved.

I've had the same issue. It was taking near 4 minutes to load the dashboard without any idea of what was happening.
Tried everything. Even ssl certificate renew, disabled authentication...
Then I decided to change the log levels.... nothing.

So I've wait the request to end. The dashboard finally displayed. I went on the "configuration node" menu. And I had many unused config nodes. Because of uitable examples I had tested on tabs. I had deleted the nodes and the tabs but the configuration nodes were still there.
I deleted them. And some other group nodes (that I shouldn't have deleted!!).
Every thing now works well.
So I think unused config nodes were slowing dramatically the ui. Wanted to share my experience.

update: I've just realized one of the group I deleted had a 4 days graph. It was probably the guilty one.
update: actually still digging....