Node Red v1.0.6 start up oddity

Quick note about the server IP address stated on start up. Incorrect on my set-up.

Welcome to Node-RED

24 Apr 11:56:41 - [info] Node-RED version: v1.0.6
24 Apr 11:56:41 - [info] Node.js version: v12.16.2
24 Apr 11:56:41 - [info] Linux 4.19.66-v7+ arm LE
24 Apr 11:56:43 - [info] Loading palette nodes
24 Apr 11:56:54 - [info] Dashboard version 2.20.0 started at /ui
24 Apr 11:56:55 - [info] Settings file : /home/pi/.node-red/settings.js
24 Apr 11:56:55 - [info] HTTP Static : /home/pi/Amicus/Images
24 Apr 11:56:55 - [info] Context store : 'default' [module=localfilesystem]
24 Apr 11:56:55 - [info] User directory : /home/pi/.node-red
24 Apr 11:56:55 - [warn] Projects disabled : set editorTheme.projects.enabled=true to enable
24 Apr 11:56:55 - [info] Flows file : /home/pi/.node-red/flows_Amicus.json
24 Apr 11:56:55 - [info] Server now running at
24 Apr 11:56:56 - [info] *****************************************************************

What is incorrect?

No such IP address in my network. In my case it should be

If you run a browser on the machine running node red and put that in as the url it should work. That is the same as http://localhost:1880. It is not telling you how to access it remotely, it is telling you the address the server is bound to.

Of course http://localhost:1880 will work. The IP address stated will not!

Have you tried? Running on the machine running node red? It works for me.

See IP Address Explained is the local loopback address for every device, This address has been shown the same in every release as far back as I can remember. Just try it. In your browser (running on the same machine that Node-RED is running) enter and see what happens.

Ok. Didn't know that. My device is remote, not accessed directly, only via IP, which makes that of no value for me. Pretty sure I used to see the proper Dashboard IP address (using the LAN IP) on start up, maybe never noticed that "local loopback" one.

Depends how you start node-red. If you use the node-red-start command, the service wrapper will show you an external address

Not for me (on Ubuntu, installed via Pi script, so running under systemd).

As you are wont to say. Show me the log !

I assumed you would just believe me :slight_smile:

 $ node-red-start

Start Node-RED
Once Node-RED has started, point a browser at
On Pi Node-RED works better with the Firefox or Chrome browser
Use   node-red-stop                          to stop Node-RED
Use   node-red-start                         to start Node-RED again
Use   node-red-log                           to view the recent log output
Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
Use   sudo systemctl disable nodered.service to disable autostart on boot
To find more nodes and example flows - go to
Starting as a systemd service.
24 Apr 20:47:01 - [info]
Welcome to Node-RED
24 Apr 20:47:01 - [info] Node-RED version: v1.0.4
24 Apr 20:47:01 - [info] Node.js  version: v12.16.2
24 Apr 20:47:01 - [info] Linux 5.3.0-46-generic x64 LE
24 Apr 20:47:02 - [info] Loading palette nodes
24 Apr 20:47:03 - [info] Dashboard version 2.20.1-beta started at /ui
24 Apr 20:47:03 - [info] Settings file  : /home/me/.node-red/settings.js
24 Apr 20:47:03 - [info] HTTP Static    : /home/me/.node-red/static
24 Apr 20:47:03 - [info] Context store  : 'memoryOnly' [module=memory]
24 Apr 20:47:03 - [info] Context store  : 'file' [module=localfilesystem]
24 Apr 20:47:03 - [info] User directory : /home/me/.node-red
24 Apr 20:47:03 - [warn] Projects disabled : editorTheme.projects.enabled=false
24 Apr 20:47:03 - [info] Flows file     : /home/me/.node-red/flows_tigger.json
24 Apr 20:47:03 - [info] Server now running at
24 Apr 20:47:03 - [info] Starting flows
24 Apr 20:47:03 - [info] Started flows

Ah, just noticed the extra line at the top. I thought you meant it changed the server line.
Ooops, sorry.

1 Like

Maybe I can ask you an off topic Q here. I have 4 unassigned groups in Dashboard I cannot find to delete. They appear in all ui items (drop downs, as [unassigned] ) but not in the right hand sidebar so I can't manage them (out). Also, there is a little note under the Dashboard layout dialogue box suggesting I "click here" to get rid of unassigned groups but clicking it doesn't do anything.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.