Node red wake on lan node


#1

Hi guys, I wanted to use node red to do wol on my local pc, so I have installed wol node, all works but! After some time, let's say an hour or so, after my pc got switched off, my wol flow will stop working and it won't wake up my pc. This is really strange as my pc can still bo woken up from my mobile.

It looks like nodered would go to sleep but its not because I'm running 24hr dashboard on it and it works but wol doesn't.

Could you share any ideas where to look for to get it fixed?

Thank you


#2

We would need to know more. sharing your flow would be a good place to start.


#3

hi, sure, flow attached:

[{"id":"d821681.ed8f898","type":"switch","z":"2ece73b8.ff014c","name":"","property":"payload","propertyType":"msg","rules":[{"t":"false"},{"t":"neq","v":"false","vt":"str"}],"checkall":"false","repair":false,"outputs":2,"x":270,"y":640,"wires":[["584eed57.1b7a84"],["1f697c1c.7f3674"]]},{"id":"584eed57.1b7a84","type":"change","z":"2ece73b8.ff014c","name":"ping false/off","rules":[{"t":"set","p":"colour","pt":"msg","to":"#FF5500","tot":"str"}],"action":"","property":"","from":"","to":"","reg":false,"x":450,"y":580,"wires":[["afdab7ff.68de98"]]},{"id":"1f697c1c.7f3674","type":"change","z":"2ece73b8.ff014c","name":"ping success/on","rules":[{"t":"set","p":"colour","pt":"msg","to":"lime","tot":"str"}],"action":"","property":"","from":"","to":"","reg":false,"x":440,"y":700,"wires":[["afdab7ff.68de98"]]},{"id":"651e877b.f8fc38","type":"ping","z":"2ece73b8.ff014c","name":"pc check","host":"192.168.0.127","timer":"15","x":100,"y":640,"wires":[["d821681.ed8f898"]]},{"id":"afdab7ff.68de98","type":"ui_button","z":"2ece73b8.ff014c","name":"wol","group":"83999c6c.55fb9","order":2,"width":"2","height":"1","passthru":false,"label":"","color":"{{msg.colour}}","bgcolor":"","icon":"fa-desktop fa-2x","payload":"","payloadType":"date","topic":"","x":470,"y":640,"wires":[["78b3e098.207b"]]},{"id":"78b3e098.207b","type":"wake on lan","z":"2ece73b8.ff014c","mac":"D8:CB:8A:86:5F:9D","host":"192.168.0.127","name":"M73 WOL","x":660,"y":640,"wires":[]},{"id":"83999c6c.55fb9","type":"ui_group","z":0,"name":"Misc","tab":"d19fc407.ce3038","disp":false,"width":"4","collapse":false},{"id":"d19fc407.ce3038","type":"ui_tab","z":"","name":"SALON","icon":"fa-couch"}]

#4

Hang a debug off the button output to check you are getting what you think you are wanting.
Most dashboard nodes don't pass on values if they haven't changed so maybe this is what you are seeing.


#5

Hi there, thank you, after pressing the button a timestamp is being
sent, and that works when computer has been turned off for around
minute or two. When PC is off for longer then WOL doesn't work from
node-red BUT works from wol app that I have on my phone.
It's just strange that after that some time has lapsed WOL won't work.


#6

and does the dashboard send the timestamp after that longer period when you press the button ?
Where is Node-RED running ?
(Hopefully not on the machine that has been sent to sleep.... :slight_smile:


#7

Ah, this is very good question! I have not checked if that timestamp
still goes out after pressing the button, so I will hook something up
to check that. But on the other thought, if other buttons work and are
programmed to send timestamps, why wouldn't this one?

I run node-red on raspi3 - 100% not the machine that I want to wake up
:smiley: haha thanks for that :wink:


#8

Ok, tried it overnight and button still does work but wol doesn't, it does from other device though. I will raise issue in github with the creator of wol node. Thank you


#9

so after the night you press the button and the debug says it works ? and the wol packet never gets sent. ?


#10

Hi there, yes - that is exactly what happens. And just to confirm - I
then took my phone out, fired WOL app and sent magic packet and it
worked instantly.


#11

Continued over on Issues list