Wake on LAN (WOL) node not producing any packets

Node-RED version: v2.2.0
Node.js version: v16.13.2
Windows_NT 10.0.19044 x64 LE

I made the simplest flow imaginable, an inject node to trigger a WOL node, set up for manual trigger.

Using Wireshark I see no WOL output from Node Red.

I have confirmed Wireshark is OK by using another app that reliably generates WOL packets to the same device.

As always, the question is "What am I doing wrong?" :upside_down_face:

P.S. I have a very complex flow working quite nicely except for this function.

        "id": "12344db4c283ea5b",
        "type": "tab",
        "label": "Flow 1",
        "disabled": false,
        "info": "",
        "env": []
        "id": "0453865593cebf9b",
        "type": "wake on lan",
        "z": "12344db4c283ea5b",
        "mac": "E8:EB:1B:CD:47:6B",
        "host": "",
        "udpport": 9,
        "numpackets": "3",
        "interval": 100,
        "name": "",
        "x": 580,
        "y": 200,
        "wires": []
        "id": "0f9feda1dc3151b1",
        "type": "inject",
        "z": "12344db4c283ea5b",
        "name": "",
        "props": [
                "p": "payload"
                "p": "topic",
                "vt": "str"
        "repeat": "",
        "crontab": "",
        "once": false,
        "onceDelay": 0.1,
        "topic": "",
        "payload": "doit",
        "payloadType": "str",
        "x": 350,
        "y": 200,
        "wires": [

Is node red running in a container? Docker for example?

[Edit] Sorry, should have said welcome to the forum :slight_smile:

Hello @aa777888-2,

Well, welcome to this forum :slight_smile:

As a PC, or any other device, that supports WoL, has no IP address, until it is powered up, you should not use its IP address, but you should use the broadcast address of the network, your device is attached to. In this case

So change your configured Target Address from into

It will get its IP address during the boot process, either as a static address, if configured, or by dhcp.


Not in a container or docker, or even as a service. Just straight Windows, launched from a command window.

But, more importantly: I'm such a dolt! I just saw "IP address" and didn't read the fine print in the box, which clearly says use x.x.x.255. I changed that just as you suggested and BAM, it's working :slightly_smiling_face:

Thanks so much for the quick reply!

I am surprised that stopped it sending anything at all.

Hello, @Colin,

If the PC, or any other device, that supports WoL, is sleeping, the ARP resolution of e.g. will fail and the packet is not deliverable. So, as it did not receive the MAC address, it should broadcast the MAC address.

An alternative is to add the MAC address to the static ARP table, but it is easier to broadcast.


I realise that as configured it was not going to achieve anything, but rather than sending nothing should it not flag an error?

That should then be done by the WoL node.
I do not know, if that is implemented.

I'm just feeling lucky someone coded a WOL node!

I'm brand new to Node Red and I've already been stymied many times, looking for nodes that to me seem like they should obviously exist. So whenever I find one that even comes close I'm happy.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.