Node-RED with S7-317 CPU - "Error: connect ECONNREFUSED 192.168.0.1:102"

Hi All!

I want to read and write a DB in a S7-317 CPU (317-2FK14-0AB0).
I setup the Node-RED like below:


I tried to change slot numbers, I tried to modified the IP of the CPU as troubleshoots, but nothing helped. I do not find a proper description to setup the communication between S7-300 and Node-RED with Simatic Manager. I know, that in TIA there is additional steps to do, but I want to use Simatic Manager with S7-300 CPU!

What am I doing wrong? Why the CPU is offline?

I only use 1 variable. I tried other as well without any success.
image

Anybody? Anything? Do you see this question?

moved to "Industrial" thread as not about creating nodes.

Have you tried other slot numbers like 0 ?

I don't know anything about that node, but the EHOSTUNREACH error generally means that there is a fundamental problem getting to the device via the network.

  1. What is the IP of the device running node-red?
  2. Are they on the same local network?
  3. What hardware/OS is node-red running on?
  4. How was node-red installed? Did you use Docker for example?
  5. Can you access the device from the node-red system using a different client application?

Hello!

Sorry for the late answer!

The problem was with the network. They were not on the same local network. I forgot to setup the correct static IP for the Raspberry.