Nothing on debug panel output

this is my configuration:
Rapberry 4 with rasbian 10
Node red Version v1.2.7
Node.js v12.20.1
A very Simple flow nothing shows up on Debug Tab.

From the console of Chrome I find this websocket error:

Any idea?
Thx a lot!!

What url are you using to access the editor?

The screenshot shows the editor is trying to use ws://http//192......:1880/ as the url for its websocket connection back to the runtime. That is wrong - it shouldn't have that extra http// in it. But as the editor generates the ws:// url from the url you are accessing the editor on, something odd is happening. Hence why I ask how you are accessing the editor.

Hi @knolleary
I try to connect with ip “http:192.x.x.x :1880” and host name “http://raspberrypi:1880/” with same result nothing to Show.
I used more Browsers and conncect directly Pi4 to my laptop over ethernet.
The only thing i did is edit ~/.node-red/settings.js for the credential secret.
The error is my fault for debugging I lanched on the Chome console this script:

var webSocket = new WebSocket('ws://');
webSocket.onmessage = function(data) { console.log(data); }


@zemmo a couple questions for you.

  1. Did you install Node-RED using the script in the documentation? If not, shutdown Node-RED and run it.
  2. what device are you using to access NR? A Windows computer, Mac? A keyboard/monitir connected directly to the PI?
  3. can you ping the Pi's IP address? Open a terminal window and type ping -c 3
  4. why are you usinig both the 'ws' and 'http in var webSocket = new WebSocket('ws://');

Hi @zenofmud,

1-Yes I used it and Today I installed everything on a clean system, but the problem persists.
2-I have used two notebook with Win10 Pro, I enabled the ssh on Pi but is also connected with keyboard and monitor.
3-Yes I ping correctly the raspberry,
4- It is my mistake yesterday I wanted to check the webservices

Do not be offended, but I have to ask this as we do not know your experience level.
The screenshot you posted shows the flow is not deployed, I have to ask whether you have Deployed it and then have clicked the button on the end of Inject node.

If you have then can you stop node red in a terminal and then start it again and copy/paste the startup log here please, including when you click the button on the inject node.

Have you ever had a working system?

None taken, I'm started Saturday, I'm a dummies.
@Colin I didn't deployed the flow.
Yesterday I bought a book and I tried many flow.
Work like a charm

Thx for the quick support :slight_smile:

Glad to be of help.

I recommend watching this playlist: Node-RED Essentials. The videos are done by the developers of node-red. They're nice & short and to the point. You will understand a whole lot more in about 1 hour. A small investment for a lot of gain.

thx @colin I will see

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.