Npm publish isn't updating (solved)

I've just spent to time fixing issue with my node-red-contrib-mytimeout code. I've updated github and changed the version in package.json to "2.0.0" (and again to "2.1.0: based on old Google group threads) but I still don't see an update on I do see the update on I've simply done an npm publish after all my updates and push to github. Am I missing something or do I just need to be patient?


There's an open issue with npm on this: New node didn't show up on this site

As it does seem to have picked up the version on npm - you can also give it a poke manually - by logging into the site (with your github id) , find your node and then request update

Huge thanks, I'll keep that in mind. I have learned something new.

Thanks :slight_smile:

Dceejay, as soon as I figure out how to mark this solved I will. :slight_smile:

Sorry, but i have the same problem...when I press request refresh is update immediately?


The update should happen within 20 minutes of you clicking the button. What module are you trying to update?

this nodes

But maybe there are a problem with npm

That link 404's for me - which is odd because I can see someone clicked the refresh link for it 30 minutes ago and I don't see a log event to explain when the page now 404s.

But I also npm search results are currently blank for whatever you search for... some something is wrong. Will investigate.

@Folgore there is something odd about the file permissions of the files in your published module that is breaking the flow library code that tries to process the update. It also appears to have multiple desktop.ini files that should not be in there.

The issue appears to be the iotgemini directory is read-only, so my code that unpacks the module to examine it cannot do so. I will look at our code to see if we can handle that better, as clearly the normal npm command line handles it.

Could you try publishing a new version with the permissions fixed?

Ok, I tried to solve the problem for permission and the file. Sorry for my request.


Sorry @knolleary, yesterday evening I have tried to publish a new version. For permission, you mean a permission of the file (I try)?


@Folgore - just checked the flow library and once I cleared out the old version it has now successfully updated your module to the latest. So whatever change you made was the right one!

Thank'you very match :smiley:

Sorry @knolleary, I am having the same problem with file .ini . Now I resolved the in the new version. For you in node-red is OK? Because I cannot see the latest vesion on library flow.


Fixed and now on the flow library.

I have another problem....but I have published...but on node-red doesn't appear a new version.


Have you gone to the node's page in the flow library and requested a refresh?

As described in the pinned post on the forum: ⚠️Flow Library not detecting updated modules

Thanks, I wasn't aware of the npm issues