Opcda-red error: Unexpexted PDU from server

Hello all!

I have error with reading data from OPC DA server. I use opcda-read node for this purpose. Node-Red is running on the Windows 10 system, OPC DA server on other Windows XP machine. Connection estabilished, reading data worked well (Status: Connecting --> Ready --> Good Suality (after reading the data)) but after a while I got an error message mentioned in title. I can't recognise the source of the issue. What solve this issue is only restart server side pc (I mean restarting the Windows). Tried to restart client side Node-Red, redeploy or reboot the whole Windows 10, but nothing solved. If error occurs then I cannot read data normally with other software (OPC Scout) on the client pc normally anymore. Screenshot from the Command Promt.


Important is that the connection and the data transfer was good, and after a while with unknown reason this error happens. Can anybody help me to solve this issue?



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.