Options missing in palette manager

I tried to use the palette manager to update the dashboard a while ago and found I only have a disable option.
I read here that it is likely that npm is not available so I checked the startup in the logs and there is no mention of anything missing:

I'm running NR in Docker and when I used the npm update from a terminal inside the container it updated just fine, as evidenced by the dashboard being at v2.22.0 above.

This is not a big problem for me but it would me more convenient if the palette manager worked fully.

Thanks for any tips.


The update button will only appear if there is a newer version.

I saw that announcement of the new dashboard this morning. That's what prompted me to go there to do the update. Failing that, I went with the npm command. I didn't take a screenshot before I updated and I now realize that would have been better to illustrate the issue. Trust me, it wasn't there. :wink:

Although the dashboard npm version had been updated to v2.22.0, the node-RED flow library had not been updated, and was still at v2.21.0, therefore an update was not available.

A couple of hours ago I initiated a refresh of the flow library, which updated the dashboard to v2.22.0, and was therefore then available to be updated in node-RED.

1 Like

Ah, OK. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.