Palette editor disabled : npm version too old

After doing one of my periodic Raspbien stretch updates (using the typical update and upgrade commands), I am receiving the following error when NR starts:

Palette editor disabled : npm version too old. Requires npm >= 3.x

My current version of npm is 1.4.21 and that seems to be the latest available for this platform. The Palette editor does not appear in the menu.

Running Stretch 9.9


What version of NR are you running?
Have you updated NR using the script?
have you googled directions on upgrading npm?

Hi Paul,

Thanks for the quick response

Running v0.19.4 of NR. Apparently, I didn’t use the install script properly to upgrade. However, when I did finally run it (as root), it upgraded my NR to v0.20.7 but deleted all my flows and user installed nodes (the flows are actually still in the flows_.json file and can be imported). I’m going to a backup and try the whole process again but I assume that running the install script should restore the flows and user nodes or is this incorrect?


Ken Kayser

Tobaccoville, NC

No need to do it again. Run


and it will show you the name of the flows file it is running. Then replace that with the original flows file and restart node red again.

On the other hand, if by running it as root you mean you actually logged in as root and ran the script then you could be in trouble. I think that if you ran it using sudo then you may be ok. You should not have done that of course.

Hi Colin,

Well, I seem to have created several problems for myself. The “Script” wouldn’t run for me unless I ran it as root even under sudo. So now the user is root and all it’s looking in the wrong directories for the flows and nodes. However, I should have just run it as the normal user without trying to run it under sudo. I think that will work and hopefully solve my self created issues. Thanks much.

Ken Kayser

Tobaccoville, NC

OK. When I do what I'm supposed to, it works as it should. lol I will close this issue as solved. Thanks for all the help