Password adminAuth not working

New user here.
I have enabled adminAuth using the default user/pass. It worked great. Once. Now when I open the workspace it doesn't ask for credentials, it just opens like adminAuth is not enabled. Tried Edge and Chrome, and with both the first time I connect it asks for user/pass, then every time after it doesn't. I am not letting the browser store the credentials in their pw managers.
I've hashed up a new pw but no luck.

Thanks for any help,


This is normal and working as expected.

The token for your session is stored in your browser's local storage after you log in. It has a validity of one week.

So if you're not using a private window/tab ("incognito mode") or clear your data on exit (or explicitly log out), you will stay logged in.

I was about to write a post for the same issue....

can this be changed to say one hour ?

My guess would be via settings.js. But it's undocumented, so you'd have to try it or ask one of the developers.

EDIT: It is documented, but not in the settings.js by default. See Nicks comment below. :flushed:

Documented here: Securing Node-RED : Node-RED

1 Like

Ah, thanks Nick.

I have only looked in the settings.js for that. :slightly_smiling_face:

Thank you for the quick and useful information everyone! I do appreciate it. I will try the recommendations.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.