Pi cannot reach internet after update

I realize this is not specifically node red, I monitor this forum and would have to hunt for a pi specific forum. If this is too far a reach please delete this post.
Pi running node red fine then did an update and afterwards could not access the node red programmer. On the pi itself I can run - sudo apt-get update - and it reaches the appropriate websites. If I open the chromium browser it won't see the network. If I try to ping out it won't see the network. Took out that SD card and put in a fresh install and the issue remains with a fresh install of 2020-08-20-raspios-buster-armhf on a pi 4 with 4 gig ram. Googling the internet doesn't turn up an answer. Any thoughts at all welcomed.
Thank you

A little more detail would be helpful.
What did you update? Was it node-red or something else?
You say you cannot access node-red, did you start it up after what ever update you did?
Go to a terminal window and enter `node-redo and copy and paste here what shows up.
How did you install node-red in the first place?

on the Pi I opened a prompt and did sudo apt-get update then sudo apt-get upgrade -y which updates the pi. Didn't pay a lot of attention to the packages listed. Then I reran the install script for node-red
bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)
Then I opened node-red on the pi and started node-red programmer and updated any packages that needed it. Only then did I try to access the programmer from across my network. Unable to access the pi at all. IP not found, went back to the pi and tried to ping from the pi to the internet, network unavailable, tried to ping my router, network unavailable, opened chromium and tried to access microsoft.com, site not reachable, go to google.com and the site comes up. I can run node-red locally and program locally but it is not reachable from any other device on the network. Yet, if I do sudo apt-get update the sites come up and the packages are interrogated. This is not specifically node-red but a pi network issue. I got another SD card and loaded up the latest image which is 2020-12-02 and before I even load node-red the network does the same strange google.com loads, microsoft.com doesn't yet it will update and upgrade. I then took the SD card and loaded the older image 2020-08-20 and the network does the same strange things. Can't ping the internet, can reach the update sites and it will update, google.com loads microsoft.com won't. I set the DNS to thinking it might be a router/DNS issue but that didn't change anything. All other devices run and I have 4 other pi's running but I certainly don't want to either update the OS or node-red until I sort out the issues with this pi. The other ones aren't mission critical but it would not be good to be without them. The one that is down is my test pi.
I ran node-redo and it says command not found.
At this point I haven't installed node-red again.

So to be clear, you are saying that with a new SD card, flashing it with the 2020-12-02 image (which flavor?) you are having issues accessing some sites on the internet but you can access other sites. True?

  1. Is the Pi connected to your network via WiFi or a cable? If WiFi only, can you plug it into your network with a cable and see if that works

This doesn't seem to have anything to do with Node-red and you might want to open a thread on the https://www.raspberrypi.org/forums/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.