Problems to update node-red

running the update command

bash <(curl -sL

my Raspi tells me:

Sorry - cannot connect to internet - not going to touch anything.
node-red - npm is not reachable.
Please ensure you have a working internet connection.
Return code from curl is 0

Running the command without bash Raspi shows me the script of this command.

A ping to works perfectly. What can I do to run the update from 1.3.2 to the latest version?

Regards Eberhard

Do you get a reply from the server if you do a ping command ?


Is the date / time correct on your Pi ?
(wrong date could cause certificate issues connecting to some sites)

edit (sorry .. so the script downloads and starts the installation process and then fails .. thats why you tested pinging npm?)

Did you run ?

sudo apt update
sudo apt full-upgrade

Can you ping
Can you open that in a browser?
If not then that is the problem. If you can then try again in case it was a temporary issue. If still not working is there anything in /var/log/nodered-install.log?

[Edit] Also what happens if you
curl -I

1st question: I can ping
2nd question: I'm using the RasPi headless without a browser
3rd question: There are multiple entries concerning nodered-install.log in that directory. The lastet entry is empty.
4th question:

HTTP/2 200
date: Fri, 12 Nov 2021 09:59:39 GMT
content-type: application/json
cf-ray: 6acee8a6380b7168-DUS
accept-ranges: bytes
age: 129
cache-control: public, max-age=300
etag: "26f3b53d536dc00b7a59f7193e12fb7b"
last-modified: Tue, 26 Oct 2021 09:44:52 GMT
vary: accept-encoding, accept
cf-cache-status: HIT
expect-ct: max-age=604800, report-uri=""
x-amz-replication-status: PENDING
server: cloudflare

1st question: I can ping raw.
2nd question: date/time is correct
last question: I ran sudo apt update - ok, but within the sudo apt full-upgrade the connection to the RasPi was refused by Putty. I'm afraid that the upgrade was not finished perfectly. Can I run the full-upgrade once more?


The log file is rotated regularly. Run the script again and see if you get a non-empty one. Or the last one that is not empty may already have the information.

Did you try running the script again in case it was a temporary issue?

Yes, hopefully. An upgrade that fails half way through can occasionally be disastrous.

Now I have tried to update/upgrade ubunto again an - lucky - i was successful. Then I removed the rmote connection and connected the RasPi direct via HMDI/USB. Then the Installation of the new version was installed without any displayed errors during the installation. The file nodered-installed.log shows a lot entries, but that all means nothing to me.

nodered-install.log (11.0 KB)

Are there remarkable errors or warnings?

Thanks to both of you for your help to this point.


No, that is all ok.

Thank you so much, Colin. You made my Day!

Regards Eberhard

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.