Potential bug with shortcuts

Hey team,
I tried to bind SHIFT+ and SHIFT- to Enable/Disable Selected Nodes, but only Disable seems to work.
I tried binding Enable to other keys ( just + and ] ), but that didn't work either.

Can someone confirm this is working, please?

Also, it would be awesome to have an action for "Toggle Enable/Disable Selected Nodes". This way we could use a single key binding.

All the best!
Dax.

(I am new to Node-RED, but have beta tested for software devs for over 13 years, mostly as UI/UX consultant.)

I also just discovered that if a key is already bound to another action, there is no warning message displayed to tell the user. Ideally, there would be a modal which asks if you want to re-map the key or leave it bound to it's current action.

Hi @daxliniere

thanks for reporting. I can confirm that any shortcuts involving the + key weren't working - now fixed for the next release.

There's some more room for improvement - particular for non QWERTY layouts - but this will do for today.

I'll take a look at your other pieces of feedback - helping avoid duplicating a shortcut and a toggle action. Both sound reasonable, just a bit more than a 2 minute fix on a Sunday morning.

Hey knolleary,
Thanks for the super-quick response and fix. Really awesome!

I did spot another issue with shortcuts last night as well. I had assigned 'g' to grid snap, then I was typing "message" and I kept getting "messae".. then I realised it was the key binding I had created. I removed that binding and was able to type correctly.

The strange thing is that WASD are also assigned, but don't have that problem. Is it possible a special exception was added for those keys, but not automatically for all key bindings?

Thanks again,
Dax.

Make sure you set the scope of the shortcut to 'workspace' not 'global' - that means it is only active if the workspace has focus. This is how the WASD keys are scoped.

Ahh cool.
It would be great if there was a warning when characters like that (and also the SHIFT modifier combinations) were bound to a command, too.

Thanks again!