Problem with updating node-red

When I update node-red to the latest version, an error occurs all the time:

npm ERR! code E404

npm ERR! 404 Not Found - GET - User not found

npm ERR! 404

npm ERR! 404 '@node-red/runtime@0.20.7' is not in the npm registry.

npm ERR! 404 You should bug the author to publish it (or use the name yourself!)

npm ERR! 404 It was specified as a dependency of 'node-red'

npm ERR! 404

npm ERR! 404 Note that you can also install from a

npm ERR! 404 tarball, folder, http url, or git url.

npm config set registry - didn't help

Has anyone encountered such a problem? How can I fix?

What computer and operating system are you using?
What command are you running to upgrade node-red?
What does the command
npm -v

npm -v
node -v
MacBook Air (13-inch, Mid 2013)
macOS Mojave 10.14.5
I used command: sudo npm install -g --unsafe-perm node-red

How many times have you tried? It could have been a temporary issue with the npm public repository.

probably 30 times. I deleted the node js, installed again, and so on in few different ways. nothing helps. google also didn't help

What network are you on? Home, office, mobile?

The issue is with whatever is responding to the request to Maybe something is getting in the way on the network.

I tried to update at home and in the office. Could you tell me what could be the problems with the network and how to identify them?

I have no idea what could be causing this. Sorry.

If the log output is to believed then an HTTP request to the public npm repository is returning a 404.

Have you tried opening in your browser? Does it load?

yes, it opens in the browser. anyway thanks for the help