Problems with node-red

Hi, i installed the broadlink node and since than my node-red hardly responces...

Anyone a sugesstion how to handle further ?

23 May 21:20:21 - [info] Node-RED version: v1.3.5
23 May 21:20:21 - [info] Node.js  version: v12.21.0
23 May 21:20:21 - [info] Linux 5.10.17-v7l+ arm LE
23 May 21:20:22 - [info] Loading palette nodes
23 May 21:20:25 - [info] Dashboard version 2.29.1 started at /ui
23 May 21:20:25 - [info] Settings file  : /home/pi/.node-red/settings.js
23 May 21:20:25 - [info] Context store  : 'default' [module=memory]
23 May 21:20:25 - [info] User directory : /home/pi/.node-red
23 May 21:20:25 - [info] Projects directory: /home/pi/.node-red/projects
23 May 21:20:25 - [info] Server now running at
23 May 21:20:26 - [info] Active project : Domotica
23 May 21:20:26 - [info] Flows file     : /home/pi/.node-red/projects/Domotica/domotica_omgeving.json
23 May 21:20:26 - [info] Starting flows
23 May 21:20:26 - [info] Started flows
23 May 21:20:27 - [info] [sqlitedb:9a3792e2.b2a75] opened /home/pi/pvkbeheer.db ok
23 May 21:20:27 - [info] [mqtt-broker:mqttdomoticz] Connected to broker: mqtt://localhost:1883
(node:7301) Warning: Setting the NODE_TLS_REJECT_UNAUTHORIZED environment variable to '0' makes TLS connections and HTTPS requests insecure by disabling certificate verification.
<--- Last few GCs --->
[7301:0x2e88428]    75332 ms: Mark-sweep 257.7 (261.1) -> 257.7 (261.1) MB, 296.7 / 0.1 ms  (average mu = 0.239, current mu = 0.000) last resort GC in old space requested
[7301:0x2e88428]    75732 ms: Mark-sweep 257.7 (261.1) -> 257.7 (261.1) MB, 399.9 / 0.1 ms  (average mu = 0.147, current mu = 0.000) last resort GC in old space requested
<--- JS stacktrace --->
FATAL ERROR: CALL_AND_RETRY_LAST Allocation failed - JavaScript heap out of memory
nodered.service: Main process exited, code=killed, status=6/ABRT
nodered.service: Failed with result 'signal'.
nodered.service: Service RestartSec=100ms expired, scheduling restart.
nodered.service: Scheduled restart job, restart counter is at 1.
Stopped Node-RED graphical event wiring tool.
Started Node-RED graphical event wiring tool.

Something is using up all the memory. Stop node red then restart it using
node-red --safe
and it will start the editor without starting the flows. You said that it was since you installed the broadlink node (whatever that is). Have you configured and wired up a broadlink node or is it installed but not in use? If it is not in use then uninstall it again and see if that fixes it (the flows will start when you deploy). If it is wired up then disconnect it and see if that fixes it. It may not be the node that is at fault but something you are doing with it.

Which broadlink node is it?

ok, did knew the safe-mode, i can access now,,, deinstalled al the broadlink stuf but the problem still exists...
Looks like i cant execute domoticz and node-red on the same rpi 4b 8mb anymore,...
When i deinstalled broadlink from the palette,is it then also removed from OS ?

I have no idea what you mean by that.

If you still have a problem then it wasn't that node causing it. It was something else that happened.

When you remove a node from node-red do you also remove it from the operation system, other words, totally deleted and no options to interfere..

@update: i think i found the disturbing issue, i think it has to do with mqtt.
I disabled mqtt in domoticz en now my node-red responces well!
I can see that mqtt has new options in node-red node. Maybe i have to change some of these to get this problem solved.
Not an mqtt expert, perhaps somebody has optimized it with the same kind of setup like me:

rpi 4b-8, latest buster, domoticz with mqtt plugin latest beta, node-red latest beta

Most likely you have an mqtt feedback loop setup... ie you send something from Node-RED to Domoticz which then updates something and sends it back to Node-RED which then feeds it back again... eg a switch ? maybe ?
The other possibility is that you may have set up two clients with the same clientID (normally it's easier to leave them blank to be assigned randomly) - if they are the same then they will take turns knocking each other off the system thus wasting time and resources.

Yep, i also think it must be something like that!
i am gonna cleanup my config and disable the mqtt out of my NR to check!.
Problem is that i think you cant config which domoticz devices are send by domoticz to mqtt, it looks like all or nothing...

yep , was indeed a loop, solved !

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.