Projects option doesn't appear - settings.js file seems to be right


I've tried to set up the Projects feature by editing into my settings.js file and restarting Node-red (and rebooting the server) but the Projects popup as mentioned here (Projects : Node-RED) never appears.

When I look into my settings.js file it seems to be correct. This is the relevant section. What am I missing/doing wrong? Help please!

    projects: {
        /** To enable the Projects feature, set this value to true */
        enabled: true,
        workflow: {
            /** Set the default projects workflow mode.
             *  - manual - you must manually commit changes
             *  - auto - changes are automatically committed
             * This can be overridden per-user from the 'Git config'
             * section of 'User Settings' within the editor
            mode: "manual"


Oh lord...the embarrassment. I rebooted the server again and lo and behold, the projects popup appeared.

If at first you don't succeed, reboot one more time.


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.