QR decode shows error

I have attached the usb camera with my computer and I am using "usbcamera" and "qrdecoder.
but I got error in payload massage as shown in the below picture.

Well first off, name your debug nodes so you can tell which message goes with witch node. Next change the `debug nodes to display the complete msg object. That could give you more information to figure this out.

Also, what format is the data coming from the camera node and what type of data I’d the qrdecode looking for?

Now I got the following information

Below picture shows the setting of "usbcamera".

And in QR, I have a web link.

I've not used that camera node - but you probably don't want "file mode" - what are the other options ? (You probably need it to just send the complete image to the qr decode node - not just save it to a file and send the file name)

The following option are there

And what is the qrdecoder looking for as input?

if you look at the readme, it wants the absolute parh to the image file. Have you defined that?

I just looked at this and dug in a bit. I would not be confident in it:

  1. The node hasn't been updated since Oct 30, 2019
  2. there is no documentation
  3. in my test, it returned an error that is meanless

It looks like you do have to pass in a single buffer of the image. So you would have to change the camerausb node to pass on a buffer. You can try that and see if it will woork.

I have tried the buffer in "usbcamera" but still I got error.
I am trying to decode QC code of a weblink.
Form "usbcamera" I got the image in ".jpg" format. but I am getting error in "qrdecoder" node.
Is the any other solution to decode the QR code in Node-Red.

Well you could try contacting the node's author look for something in node.js that would work and then create a node for it or you could add it into your flow in a function node or maybe run it with an exec node.

Try some google searches and you might find something

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.