@ralphwetzel/node-red-systeminformation does not load in ui node tools

Have installed via Pallette and also tried npm on Debian Trixie OS.
after install and node-red resstart no system information icon is seen in left ui toolbar ?

Log shows no issue or clue.

Same issue. Update to v1.0.2 and still nothing in the nodes list (shows in palette as installed)

make sure to tag the author so he gets notification of this issue.

What version of NR and node.js are you running?
When you start NR is there anything showing in the start up log?

adrian@debian:~/.node-red$ node-red
31 Dec 09:48:43 - [info]

Welcome to Node-RED

31 Dec 09:48:43 - [info] Node-RED version: v3.1.3
31 Dec 09:48:43 - [info] Node.js version: v18.18.1
31 Dec 09:48:43 - [info] Linux 5.19.0-2-amd64 x64 LE
31 Dec 09:48:43 - [info] Loading palette nodes
31 Dec 09:48:44 - [info] Dashboard version 3.6.2 started at /ui
31 Dec 09:48:44 - [info] Settings file : /home/adrian/.node-red/settings.js
31 Dec 09:48:44 - [info] Context store : 'default' [module=memory]
31 Dec 09:48:44 - [info] User directory : /home/adrian/.node-red
31 Dec 09:48:44 - [warn] Projects disabled : editorTheme.projects.enabled=false
31 Dec 09:48:44 - [info] Flows file : /home/adrian/.node-red/SPE_Linear_V1.10PC.json
31 Dec 09:48:44 - [info] Server now running at
31 Dec 09:48:44 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

31 Dec 09:48:44 - [info] Starting flows

No issues in log hereon


in /home/adrian/.node-red/node_modules/

Happens in 2 instances of Node-RED, both 3.1.3, both with node.js 18. (One instance on a Pi the other on a VM running Debian).

@meeki007, thank you for that, should have done it myself.

nodejs v 20.5 and later tried, made no differrence here, however I need v18 for a websocket flow to work properly re connection.

Thank you for this report.
Can you spot any issues in the console of your browser?

Ralph, No issues shown in browser console. Just node is missing friom Function list.

I've got the System Information node installed on both a

Mac: NR v3.1.1, Node.js v18.12.1, Dashboard v3.6.2

and a Pi NR v3.1.3, Node.js v18.19.0, Dashboard v3.6.2

and as you can see it shows up in the Palette sidebar and runs fine.

Please try Debian Trixie on a amd 64 PC please ?

I don't have a PC so that will not be possible, sorry

npx works fine ;

adrian@debian:~/.node-red$ /usr/bin/npx systeminformation info
โ”‚  SYSTEMINFORMATION                                                     Version: 5.21.22 โ”‚

Operating System:
Platform         : linux
Distro           : Debian GNU/Linux
Release          : unknown
Codename         : trixie
Kernel           : 5.19.0-2-amd64
Arch             : x64
Hostname         : debian
Codepage         : UTF-8
Build            : 

Manufacturer     : Dell Inc.
Model            : OptiPlex 9020
Version          : 01
Virtual          : 

Manufacturer     : Intel
Brand            : Coreโ„ข i5-4570
Family           : 6
Model            : 60
Stepping         : 3
Speed            : 3.2
Cores            : 4
PhysicalCores    : 4
PerformanceCores : 4
EfficiencyCores  : 
Processors       : 1
Socket           : 


If the node states to be installed in the palette manager, please try to import the provided example flow.
What's happening then?
What is the browser, you're seeing this effect in?

Google Chrome in Debian Linux, note that only your node has this effect, and all others are good and show for use, I installed the one example flow, and had the warning that the systeminformation node is missing etc ;

What version?

Chrome logo
Google Chrome
Version 120.0.6099.129 (Official Build) (64-bit)

That's good news.
In that case there must be an issue report either in the console of the browser or in the log of the runtime. Would be great if you could spot it...

Can you show us what you see in Manage Palette please?