Raspberry pi Zero v2

Hi

Has anyone tried running NR on the new Raspberry Pi Zero v2. I have two of these that both perform in a similar way.

The editor loses connection to the server when you deploy a flow. If I do not use the editor the Pi needs to be rebooted to get NR running

I have tried
Two different Pi Zero v2
Connected by wifi and ethernet cable
Different power supplies
Any help appreciated

Something similar happened to me when trying to import a big flow on a centOS server.

Were you trying to start from scratch or importing a pre-made flow on it?

If it's importing a new flow and the node-red server has some issues importing all at once, try importing it by parts, with the "deploy only modified parts" selected. Even like that, it may take some time until it can import and deploy some flows.

No problems for me with the Pi Zero 2 on wifi. Is there anything relevant posted in /var/log/syslog?

Is this with a minimal flow or have you imported one?
Stop and restart node red and post the full output here, up to the deploy.
node-red-stop
node-red-start

Thanks everyone

Update
Colin
The flows were minimal but they did include a modbus read node that was causing an error and NR to restart when I watched the output. I have removed these nodes and now the editor works. I have used the exact same flow on a old Pi zero (no wifi) and it works fine, so this could be related to the modbus node on the new pi

I am not sure this has solved all the problems because before I was using the modbus nodes I was still needing to reboot the Zero v2 once or twice a day

I will monitor over the next few days

Thanks for the help

What was the symptom that required a reboot?

Did you have any loops in the flow?

I recently had a problem with nested objects in a state machine loop that made the node-red flow stop after a while, because it went over the limit for message-size.

My guess is that in a Zero, and with its lower memory capacity, if you're handling big messages it may eventually cause problems.

Thanks for the reply
No, the flow was a simple modbus read using the modbus node. It would seem this node is the problem as Node Red works fine when it is removed and there are errors in the output relating to this node. I have tried Node Red on the Zero v2 without modbus and it works fine.
I have tried the same OS (the new one) on an old Zero with no wifi and the modbus node works fine, the conclusion is the problem is related to the modbus node but only on the Zero v2 and is also not related to the Raspberry OS

I think that is unlikely. What errors do you see with the modbus node? Also which modbus node is it (node-red-contrib-something)?

@mtoko I also had problems recently with the Modbus Read node on an Opto22 device that had its firmware updated. The problem had to do with the version of Node.js, but I have since gotten it working again. More details here.

1 Like

Just to close this thread

I formatted the sd cards and installed the new Raspberry pi OS (Bullseye) and then the modbus node and everything worked fine. It was a strange problem which I replicated on two Zero's a number of times but I just went back to basics and eventually it worked

Thanks for the advice