Re-enter credentials

#1

While trying to push a project to git for the first time I accidentally entered the wrong password. I did manage to push from the command line but now I cannot commit any changes as the authentification box does not appear and the commit fails.

#2

Node-RED only remembers the credentials you enter in memory. So if you restart NR, it should prompt you again the next time.

But in general, I would expect NR to detect the error and handle it. Is there anything in the NR log?

#3

This is an old DietPi installation, I cannot find a node-red.log file!

#4

You may be able to
sudo journalctl -u node-red -o cat

1 Like
#5

Worked Dave, but I had already restarted node-red to try Nick's suggestion, which also worked. I'll try it again sometime to see if the log shows an error when entering the wrong credentials.

#6

Running the bash upgrade from the pi instructions should add the node-red-start stop and log commands -if you wanted them. (But then advise you to upgrade via the duetpi software mechanism. )

#7

I am moving my controllers back to plain Raspbian, it's easier to keep up with. The Dietpi guys made an upgrade breaking change recently which annoyed me. Not a big thing, I am only doing home automation stuff after all.

2 Likes