Read the room temperature from BACnet room simulator

Hi, I am BACnet IP newbie. I am trying to read the room temperature from BACnet room simulator at groov epic using Node Red but nothing appears in the debug window. Please help to see the temperature in the debug window. The code inside the function node is as below-
msg.deviceId = 1474793; //

msg.address = "";

return msg;

I’d like to read temperature value from bacnet simulator. When the below code is executed then the real time value as shown in snapshot from Yabe doesn’t appear. So what more should be added to the code so that the PVs gets seen in Node red-
msg.payload = {};
{ objectId: { type: 0, instance: 1 }, properties: [ { id: 85 }] },
return msg;

If that is the entire function then the debug is doing exactly what you asked it is showing you what you put in the payload!

in other words, arent you supposed to do something with that msg? i.e. send that to a bacnet read or command node?

Have you looked for demos and examples e.g. ctrl-i -> examples -> backnet

Have you read the built-in help for the backnet nodes (check the help sidebar in node-red)?

Im not using Bacnet on node-red but only at work with PLC's, which is much more simple. I try diffrent bacnet kit from node-red pallete but i couldn't make it work, thanks to you i found the one from your post. Tested with my home automation controller Unipi which have bacnet server enable and all seems to work as expected, check the pictures.
Refering to your problem:

  1. Try to use a real bacnet device, maybe you can get second hand one from ebay or gumtre, maybe a temperature sensor or something like that.
  2. Make sure the cliend and server are on the same network.
  3. Make sure its only one client and one server, bacnet can work with multiple instances but to make sure try lkie that first.
  4. Make sure the firewall doesn't block the traffic on bacnet port.
  5. Good idea to setup point to point ethernet connection for client-server.

Check the pictures and confirm correct settings.
Good Luck!!
BacnetSampleFlow.json (17.8 KB)

Thanks for the above suggestion. Unfortunately I am unable to access NR as it keeps restarting due to inaccessible port no 1000. Even if the NR flow is downloaded & this port no of 1000 is replaced with 6001 & then this new flows.json is uploaded then also NR keeps restarting. Kindly help to prevent NR restarts & provide access to NR. Please note that I do not have access to SSH server

You need to start node red with the --safe option.
node-red --safe
Then it will run the editor, but will not start the flows, so you can edit the flow and then Deploy. It will start running the flows when you deploy.

Thanks for your reply. Unfortunately I am yet to get SSH server access hence I wonder if the above command/method will be of help. Request you to please share a method whereby node red can be accessed without SSH server

What device are you running node red on and how did you install node red?

I am running NR on groov epic & there is no access to SSH server to execute NR/linux commands

Why not? I see numerous guides online for how to do that.
I cannot see how you can manage the system without command line access.

If the project/flows are deleted using Delete Project option in Node Red-Project files, then can you

If the flows are deleted using Delete Project option in Node Red-Project Files then, can you please confirm if all the keys & certifications need to be re configured again when a new flow is created or backup flow is imported