Remote Access to NodeRed(nr)

i am running my laptop on my home net and my cerbo is connected on my rv net. i connected my laptop to my rv net and bamb, i could access nr on my cerbo.

not a big network person so not sure how to resolve this, but seems like i should be able to connect from my home net to cerbo on my rv net. thoughts on how to resolve?

sorry for all lower case, working with 1 hand due to shoulder keyboard pecking is enabled.

....this is not NR related, it's a "problem" on how to setup up and integrate your victron system.
However, there might be several options to achieve this, depending on your use case.

The most generic one would be to permanently provide Internet connection for your RV net, then enable VRM connection on the Cerbo. Because of this: Venus OS Large image: Signal K and Node-RED [Victron Energy] will be able to access NR install via VRM afterwards.
Edit: fixed Link

i have net connectio nto rv net. i run a number of apps that touch components in rv. not being a network guru its confusing why i can't access nr in my rv, where its installed on cerbo(by victron).

read the link page u provided, but unclear its effect on my issue.


...sorry, I gave the wrong link....corrected now..try this: Venus OS Large image: Signal K and Node-RED [Victron Energy]

The other link ist regarding using wireguard VPN, which is also enabled in the Linux kernel, running venus OS Large since v3.20 ... this could be another option, but without being a bit network savvy, you should not try that.

...from within your home that what you are saying? Is this a direct, local connection or via Internet?

What URL are you using from your laptop in home net to browse to the Cerbo in rv net ?

the link u gave is what i have used to get to the nr install. i was trying to gain access via a direct url like i do for local install of nr. locally i access via https://localhost:1880. was trying to gain direct access via
https://cerboIP:1880, but this does not work.

beginning to sound like i must use the vrm interface as go between instead of directly. would be nice for direct connection. makes me wonder if in the end will i have to access my nr apps i develop via vrm. that would be a big bummer.

sounds like someone is on track with a solution. true?

Well, access via port number 1880 is standard for a vanilla NR install, like on your Win11 laptop.
According to the victron documentation (see link Venus OS Large image: Signal K and Node-RED [Victron Energy]), for NR running on the Cerbo itself via VenusOS Large, the port number is 1881 ... so try https://cerboIP:1881 instead.

...that might be another option.
As I said, there may be many.
As you have access from your home net to your rv net directly already, try the URL with the correct port number as said in my other post

i have tried the direct ip to port 1881 and it does not work, thus my post....guess ill settle for vrm portal acces only til V comes out with something better.

Sorry, I am not using NR on the Cerbo...I've been under the impression, that you used port 1880 instead of the documented 1881.
I am using NR on my NAS and integrate via mqtt (which is another option, without the use of the contrib nodes).
Well, can you ping the CerboIP from inside your home net?
Can you connect to the Cerbo UI, base URL is http://cerboIP ??
If you can ping, but not connect fully to the Cerbo UI, your network setup is to blame.

i cannot ping or connect directly to my cerbo ip. not a net guru so not sure if this is on purpose by victron, or something in my config. i have opened up my cerbo for most part also.

without a crystal ball available on my side of the fence and without knowing any detail on your setup, I'd suspect it is a problem on your net config.
Seems like your home net and your rv net are not connected.
Since you can access your victron setup, that is residing on rv net via VRM, at least your cerbo has internet access from within your rv net.
So you have basically two separate sites, one is your home net with its own internet access and the other is your (mobile) rv site, with its own internet access, too.

care to elaborate what the net situation is on your side (both sites, home and rv) and how you think you have them connected - if at all?

I have 2 seperate nets, one in my house and another in my RV. How can I access resources(cerbogx), that reside on my RV net from other outside networks, eg, my house net?

So both your networks are not interconnected at this time, but each is connected to the internet, by use of its own Internet-Provider link?
The solution you need is called a VPN.
But how and what type is best to be used will somewhat depend on the way your RV and home net do connect to the internet (i.e. what Router and which Internet Service are you using) and your use-case(s).

  • ability to connect from a single device - like your laptop in your home net to rv net
  • ability to connect between any two clients/devices in home and rv net
  • ability to connect from anywhere (like from your laptop at a hotel net) to your rv net
  • ability to connect from anywhere (like a hotel) to your home net
  • all of the above

All of the above sounds like what is needed. I have avoided vpns in the past, just to minimize configuration, and my lack of expertise in this area. But sounds like I need to bite the bullet.....

Rv net - gl1300 travel router, isp connected to either starlink, or Visible cellular isp.
home net - netgear nighthawk 8500, connected to cable based isp spectrum.

So, if i setup a vpn on the rv side will that be enough to start accessing my devices in the rv from others nets?

No, it is not.

Normal VPN solutions / providers will allow you to use it as a so called access VPN.
Even if you connect two devices at the same time to the same VPN provider, devices are nor able to communicated with each other...access vpn is used to obscure your Internet location.

What you need is some kind of site-to-site site being your rv and the other your home.
In addition, like when abroad/in a hotel you need an access vpn connection into one of your sites or the site-to-site-vpn.

Maybe the best option for you is to use a SDN. like zerotier.
They have a free tier, that would do what you need.

As you mentioned the gl1300, you might be lucky that this device already supports zerotier: ZeroTier - GL.iNet Router Docs 4

With your nighthawk, I am not sure.
But as an alternative, you could simply use another device with zerotier from home and dedicated laptop/desktop to it. You can as well use this device for traveling, when away from home and away from your RV.

With the device and the ability to use/connect to a zerotier account and your zerotier network, it shouldn't be too hard to deploy - without networking knowledge/skills I mean.

If one of the devices is connected to a mobile phone ISP. I recommend looking at Zerotier.

The are other solutions mentioned in various forum posts, but a traditional VPN won't work for mobile internet.

Sounds too complicated for my purposes. Thx for the feedback on a solution. Will continue to play with nr until I gain more\better knowledge of capabilities and how they fit in the Victron world.

Also reading about its use with shellly devices, which sounds intriguing. Well the whole nr tool in general seems pretty cool now that i think about it.

Well, think of zerotier as a network-switch in a cloud.
Each site of yours (rv or home, ..) or mobile device can connect to that switch and when connected become part of a common, dedicated private network (IP-net).
It should only take you same clicks to create a free zerotier account, configure your private network and connect your RV (with router) and your home laptop (with zerotier drivers installed)
With your RV and Router connected to internet and activated zerotier, you could simply install the windows driver for zerotier-vpn on your laptop and connect only this, on demand, instead of your complete home.

The setup with routers from is quite straight forward, hence I'd recommended these for a not-so-network-savvy person.
Another option, with zerotier ready devices are Routers from Mikrotik (although RouterOS is not so easy to start with):