Issues with remote access with zerotier

Hi Guys,
I am having issues with remotely access node red dashboard via zerotier VPN. Everything seems to be fine but it just would not work.

I can ping the computer and made a firewall exception for the port 1880.

I have done this in the past with other systems with success but this time it just would not work!
Please help!

Isn't the whole point of zerotier to keep ports closed ?
The traffic goes through the tunnel, firewall doesnt see it.

If you opened 1880 on the WAN side, you can uninstall zerotier as well. I doubt you want that, so close it as soon as you can.

I am getting confused ...the last time it worked after I added the firewall exception!!

How were you reaching node-red ? ie. on which ip ? the LAN IP, the WAN IP or the zerotier IP ?

Do not open port 1880 in your firewall settings. As @bakman2 mentioned, this is indeed not needed.

If both, your remote device and your node-red server have joined your private (!) zerotier network, you should be fine to reach out to node-red via http://zerotrier-network-ip-of-node-red:1880.

Please check in your zerotier account and your zerotier network that

a) both devices are connected
b) both devices are allowed to join
c) both devices are online

you can check this in the status section of the corresponding network.

EDIT: This will only work, if you access node-red via its zerotier IP. If you choose hostname, it most likely is referring to the wrong IP or cannot find the ip at all (as long as it is not a public IP)

zerotier IP

All looks fine since I can ping all the devices

With which device are you having difficulties. The phone does not seem to be connected.

I cannot access node server PC from "SCADA" or "bikash_pc".

What exactly do you see when you try to access node server pc from one of the other devices?

A snapshot of the screen might help.

Aside, can you ping from node-red-server to SCADA and bikash_pc and vice versa?

Are these PCs located in your home or in a company network?


You might want to check Dashboard suddenly asks for password (Hacked Node-RED servers) BEFORE (or better if at all :slight_smile: ) you open port 1880.

The connection times out.. ERR_CONNECTION_TIMED_OUT.

Ya , I can both devices vice -versa. Its on my company network.

I suspect this (company network) could still be the problem? Although not likely.

I experienced something similar strange with my laptop working onsite at my client's office network. Company firewalls might indeed block traffic, although this is only a rare condition (see zerotier help).

In order to check this I'd try to connect one of the PCs (which I assume are remote) via your phone (thethering, I assume your phone works). If you could access your node-red server then indeed the company firewall seems to block something needed from zerotier.

Other than this. I run out of ideas since you can ping in both directions. Last call would be to de-install/install zerotier on those remote PCs and hope for the best :slight_smile:

Everything works absolutely fine if I tether all devices to the same network (internet) and use its corresponding IPs, in which case I don't need zerotier.

The issue begins if the network is different and I use zerotier server and IPs.

This is getting really frustrating !!

The only remaining idea that comes to my mind is the fact that you are using company PCs. They very often carry limitations to secure the company's network integrity. Hence there might be policies under the hood that do not allow this.

What type of device is the node-red system ? linux ? do you need to enable ipforwarding ? setup iptables ?

Is there any way to check whether thats the case or not?..because I had used VPNs like Radmin in the past for other purposes without any issue.

Its on windows 10..No idea about port forwarding setup etc!!

Phew ... I'd ask a friend in IT :slight_smile: ... I have no clue what these guys are doing, but I assume this could be a limiting factor. first time it worked was because I had opened the 1880 port and not because of zerotier!!