Removing node-red-contrib-netatmo-dashboard in palette failed

I tried to remove node-red-contrib-netatmo-dashboard in the palette but it failed.
Is there a way to remove this module directly in the .node-red folder?

Helps if you share the error message.

You can remove manually from a command line on the server:

cd ~/.node-red
npm remove node-red-contrib-netatmo-dashboard

Then restart Node-RED.

If it said it is still in use, but you think you have removed all the nodes, go to Configuration Nodes in the menu and make sure there is not an unused netatmo config node there. If there is you can select and Delete it.

This is what I get when removing in Node-red.
Node-Red.Dashboard is still in the Palette.
No configuration node left over


2023-12-07T09:04:07.432Z Entfernen : node-red-contrib-netatmo-dashboard

2023-12-07T09:04:09.337Z npm remove --no-audit --no-update-notifier --no-fund --save node-red-contrib-netatmo-dashboard

2023-12-07T09:04:13.128Z [err] npm

2023-12-07T09:04:13.130Z [err]

2023-12-07T09:04:13.130Z [err] ERR!

2023-12-07T09:04:13.130Z [err]

2023-12-07T09:04:13.131Z [err] code

2023-12-07T09:04:13.131Z [err] ENOTEMPTY

2023-12-07T09:04:13.132Z [err] npm

2023-12-07T09:04:13.133Z [err]

2023-12-07T09:04:13.133Z [err] ERR!

2023-12-07T09:04:13.133Z [err]

2023-12-07T09:04:13.134Z [err] syscall

2023-12-07T09:04:13.134Z [err] rename

2023-12-07T09:04:13.134Z [err] npm

2023-12-07T09:04:13.135Z [err]

2023-12-07T09:04:13.135Z [err] ERR!

2023-12-07T09:04:13.136Z [err]

2023-12-07T09:04:13.136Z [err] path

2023-12-07T09:04:13.136Z [err] /home/pi/.node-red/node_modules/node-red-contrib-netatmo-dashboard

2023-12-07T09:04:13.137Z [err] npm

2023-12-07T09:04:13.137Z [err]

2023-12-07T09:04:13.137Z [err] ERR!

2023-12-07T09:04:13.137Z [err]

2023-12-07T09:04:13.138Z [err] dest

2023-12-07T09:04:13.138Z [err] /home/pi/.node-red/node_modules/.node-red-contrib-netatmo-dashboard-9wXw9VzC

2023-12-07T09:04:13.139Z [err] npm

2023-12-07T09:04:13.139Z [err]

2023-12-07T09:04:13.139Z [err] ERR!

2023-12-07T09:04:13.140Z [err]

2023-12-07T09:04:13.140Z [err] errno

2023-12-07T09:04:13.140Z [err] -39

2023-12-07T09:04:13.144Z [err] npm ERR!

2023-12-07T09:04:13.145Z [err] ENOTEMPTY: directory not empty, rename '/home/pi/.node-red/node_modules/node-red-contrib-netatmo-dashboard' -> '/home/pi/.node-red/node_modules/.node-red-contrib-netatmo-dashboard-9wXw9VzC'

2023-12-07T09:04:13.150Z [err]

2023-12-07T09:04:13.150Z [err] npm

2023-12-07T09:04:13.151Z [err] ERR! A complete log of this run can be found in: /home/pi/.npm/_logs/2023-12-07T09_04_10_867Z-debug-0.log

2023-12-07T09:04:13.169Z rc=217


2023-12-07T12:29:55.533Z Entfernen : node-red-contrib-netatmo-dashboard

removing it on the RPI as you mentioned above some message

This is a know problem with some versions of npm that occasionally it leaves temporary folders lying about that then cause this problem. Look in the folder /home/pi/.node-red/node_modules/ and delete any folders there with a string of random letters on the end, similar to that one. Then you should be good to go.

Hi Colin,

thanks for your advice.
It worked! :slightly_smiling_face:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.