Resolving error "A duplicate file name exists, or the file cannot be found."


I'm attempting to resolve an error with my Node-Red setup that I see when using the TagUI module. The error I'm seeing is after the execution of any TagUI module:

"A duplicate file name exists, or the file cannot be found."

I don't believe it's an issue with the TagUI module itself since I can run the same flow on a different install of NodeRed and I don't see the same error. It seems like it might be related to some kind of logging to a file at the conclusion of the module's execution...?

Does anyone have a starting point for how to debug this? Some background: I have Node and Node-Red installed in my user directory, not root, as this is a work machine and I wanted to keep things contained in my directory. Not sure if this is an issue or not, but thought I'd include the info if so.

Any help is much appreciated.

I'm tempted to say "Hello Possum!" But won't! :wink:
first 3 seconds

I would beg to disagree.

(Oh, what O/S machine is this on?)
(Assuming RasPi/Ubuntu)

Open a command line/terminal.

cd .node-red

Look for any errors/complaints/problems when that starts up.

When you see what you think is the problem, get back and post.


Start your reply.

BEFORE you paste, click the little reverse tick key (the one to the LEFT of the 1 key) THREE times.
Paste the stuff.
(On a new line repeat the 3 reverse ticks)

It should look something like this (style wise)

This is an example of what you
should see if you did it correctly.

Then post your reply.

Are you the person who opened this issue on node-red-contrib-tagui's GitHub page?

If so, you should follow up with the author.
If not, you should add your voice to the thread.

  • provide information on what device NR is running on,
  • the versions or NR and node.js
  • the version of node-red-contrib-tagui you are running
  • anything else you thing is relevant.

Yes, that was in fact me posting on the Github page.

I just updated NR to 2.2.2 and that appears to have solved the problem. I was on 2.1.7 before, having installed NR a few days before 2.2 was released.

Oddly, the other machine I ran the same flow with no errors is only on 2.1.4. :woman_shrugging:

I spoke too soon. The error has returned. :persevere:

Is node-red installed in your home directory? Or another location?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.