RFXtrx433 remains 'connecting'

Hi,
I'm trying to get my RFXtrx433XL to work but it seems to fail. I connected an RFX sensor node to /dev/ttyUSB0, after which the node starts connecting, but never becomes connected.
I followed the instructions of the RFX documentation for installing on a Pi, but that manual seems to be outdated (not written for systemd configs).

I would be very happy if someone who has the RFXtrx433xl could help me getting it to work. If I succeed I'll make a tutorial for it.

These are some of my configs:
lsusb

Bus 001 Device 004: ID 0403:6015 Future Technology Devices International, Ltd Bridge(I2C/SPI/UART/FIFO)
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. SMC9512/9514 USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsmod

Module Size Used by
cfg80211 525806 0
rfkill 21373 2 cfg80211
ftdi_sio 33030 1
usbserial 29996 4 ftdi_sio
snd_bcm2835 23131 0
snd_pcm 97825 1 snd_bcm2835
snd_timer 22706 1 snd_pcm
snd 68784 3 snd_timer,snd_bcm2835,snd_pcm
bcm2835_gpiomem 3791 0
fixed 3029 0
uio_pdrv_genirq 3718 0
uio 10166 1 uio_pdrv_genirq
ip_tables 12512 0
x_tables 20921 1 ip_tables
ipv6 384532 35

dmesg | grep ftdi

[ 26.396977] usbcore: registered new interface driver ftdi_sio
[ 26.397645] ftdi_sio 1-1.2:1.0: FTDI USB Serial Device converter detected

dmesg | grep tty

[ 0.000000] Kernel command line: bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000 dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=18ff364c-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[ 0.001389] console [tty1] enabled
[ 1.059168] 20201000.serial: ttyAMA0 at MMIO 0x20201000 (irq = 81, base_baud = 0) is a PL011 rev2
[ 26.514890] usb 1-1.2: FTDI USB Serial Device converter now attached to ttyUSB0

cat ser2net.conf

10001:raw:0:/dev/ttyUSB0:38400 8DATABITS NONE 1STOPBIT

Thanks
Insomniux

You are probably best opening an issue on the nodes github page.
Max (the author) is usually very responsive, but Iā€™m not sure how often he reads the forum.

I have 'answered' this on the github page, with a request for console debug output. I haven't tried an actual physical XL transceiver yet.

1 Like

Problem solved.
Althought I actually do not understand why, the connecton was established after I disconnected the RFXtrx and reconnected it. Also after reboot the connection to the RFXtrx came up automatically so I assume this problem is solved.
Thanks all for your help

I have seen this type of issue myself - I think it is something to do with the serialport node, which has been through a lot of changes recently, and the dust hasn't quite settled. There will be an update to node-red-contrib-rfxcom/node-rfxcom fairly soon (well, fairly soon-ish) which will use a more recent serialport version, among other things.