Run Node-red on Windows10

After a while of inactivity, I try to connect to Node-Red again, but I cannot access Node-Red and my previous flows. I accidentally deleted my desktop shortcuts. does not help.
I cannot find my previous questions on the forum. That would probably help me too.

What command are you using to start node-red? Or are you running it as a service?

Do you mean this one? But that seemed to be on a Raspberry PI, instead of windows 10?

Indeed, in the meantime I have also been able to determine that those questions were about an application on a Raspberry Pi.

In the meantime, I have also found how to retrieve my previous posts (after logging in).

I am going to try to run Node-Red again on the Raspberry Pi.

Thank you for your efforts.


1 Like

If you do want to run on Windows 10, there are plenty of threads in the forum about it and how to start it as a Windows Service. Personally I run it manually under PM2 as I use it as a development environment.

Finally, I managed to restart Node-Red as before on the Rasp Pi. However, without my Flows that I made before.
Can that still be fixed, please?
I can't remember exactly which command I used, but I ran 'Node-Red start' twice and suddenly it started up with 'http://host:1880' or initially with the link 'http://127.0.01:1880'. All this reached the limit of my ability.

The command is node-red --safe note thatā€™s two dashes before the word ā€˜safeā€™.

Without the dashes, you told node-red to start using a flow file called ā€˜startā€™ which would be empty.

I running it as a service on a Raspberry Pi 3.

The command to start node red as a service on a Pi (though I am not sure what this has to do with the title of this thread) is
and to tell node-red to start automatically on boot
sudo systemctl enable nodered
That assumes that you used the recommended method of installing node-red.