Running on PLC without Internet connection

I want to run Node-RED on a IPC427E from Siemens, but it has no Internet connection.
So I have to copy all files from my PC to the IPC and Node-RED is already running.
Now I`ve copied theProjekt from my PC to the IPC, but I have 2 mistakes.
After I have prepared the MSSQL Knode and I implementate the Username and the password of the Database they were not saved, so i didn't connect to the Server...
The other mistake is if I open one funktion and close it, the function node has an error, although I didn't change anything...
I don't understand why I have this problems.

Do you have any ideas or help for me?

What sort of error is the function node showing?
Look in the node red log to see if there is any indication as to why the username and password are not being saved. Perhaps the user running node-red cannot write that the .node-red folder.

The error is:
"Connection Error: Failed to connect to WPKEMPER-PC:undefined in 15000ms"
The error says WPKEMPER-PC:undefined but I configurate the SQL-Server in the MSSQL-Node as WPKEMPER-PC\SQLEXPRESS.
What would be the fault?

Can you ping the wpk.... machine? Do you have a local dns server? If not, enter ip address instead of hostname...

Node-RED and the Database MSSQL are runnung on the same PC(IPC427E), so I only have to Name the SQL-Server which is running on this PC.
Is there anything more to configurate on the PC.
The SQL Server is Running and TCP\IP is enabled.

You seem to have changed the symptom since the first question. You said initially that you had a function node generating an error, and that you could not save the user/pwd for the MSSQL node. Now you seem to be showing an error from the MSSQL node which is not due to user/pwd saving.
Can you clarify exactly what the problem is?

We think that both are symptom of the same problem.
In our opinion the problem depends on the files we copied from a PC (the same Projekt with the same properties was tested in it) to the Siemens IPC.
If I copy the Node Red-Projekt to the IPC, the function did not give a fault. If I change anything in one function the fault come.
How can I check if all files were need are available and node-red can in any folder.
Will a Screeshot of the Node-Red Projekt help you?

Which Function node is giving an error?
Show us the code for that node.
Also look in the node-red log to see what is there.

Every Function is giving an Error if I change anything on it.
It not depend on the code in the function, the code was running on another pc either.
I've installed Node-Red and all flow packages again with internet connection, bur the Problems are the same...

Did you copy simply the n-r directory from another machine or did you import the flows in n-r?

Maybe if you just copy it, there may be some machine specific settings which prevent proper function...

You still haven't shown us what is in the node-red log.
I think maybe you are using the the word Function in an unusual way. Perhaps you mean Node? I don't see how a Function node could give the error you showed.

The problems with the functions are solved, I've installed Firefox instead of Internet Explorer and now the functions didn't give any errors.
Now the MSSQL Node give an Error.
The Error, the function who gave the String to the MSSQL Node and the configuration of the Node are shown in the pictures.
Do I have to put two backslashes before SQLEXPRESS or just one?
And how do I find the Port of The Server?
Or Are there other faults or Porblems?

Have you tried googling the ECONNREFUSED error message?

It would suggest the node is connecting…

If the DB server is running on the same machine, localhost could also work, depending on your setup.

I have some experience running node-red on Siemens IPCs - if you want you can send me your flow and I will take a look at it.