Serial Port Node not outputting data

Hello! TLDR: The Serial node is connected, but not outputting any data.

I've got NR V1.1.1 tuning on a Pi2, and a USB/Serial Barcode scanner plugged in. The USB-serial device is plugged in, connected, and showing data output -- but not in NodeRed.

The device shows up as:

  idVendor           0x0416 Winbond Electronics Corp.
  idProduct          0x5011 Virtual Com Port
  iSerial               0

And in NodeRed, it shows up as:

And in Terminal, I do see it reading data correctly if I use this command:
sudo cat /dev/ttyACM0

NR will connect, see if the device unplugs, etc, but it will not pass any data. I've also seen this same issue on an older version of NR, and NR V1.1.1 on Windows 10.

My thought is that it's a permissions issue? I've tried numerous udev tutorials on adding permissions, but none have worked so far. Thoughts?

How did you setup the NR serial node?

Here's everything in NodeRed. You can see that the serial node is connected, and via SSH, I can see the data coming across, just not in NR: Screen Shot 2020-07-11 at 6.41.34 PM|690x412

Try split input \r instead of \n or maybe both.
Else try split input "after a silence off"

If it works in a terminal program it should also work in nr.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.