Series Colors on Pie Chart

#1

How can I set the series color on my pie chart? I have changed the colors in the chart node configuration.
image
I am getting a chart that does not reflect my changes. I even restarted node-red.
image

Thanks,
Mike

0 Likes

#2

The colors are assigned per order or arrival, this means if you have set the order of the screenshoot first message will be on green whatever it is, with or without relation to the real topic or label.

Make a search on the forum as we discussed time ago on another post about this and most probably will help u to understand.

Regards

Look here:

0 Likes

#3

Hi Dave,
I understand that is based on the order of arrival. My question is why the colors do not match from the first screenshot to the second screenshot?

0 Likes

#4

You are totally right..... there is some bug... I have tested and had the same than you

image
image

Let see if some admin see the post and tell you hoy to report it.

Regards

0 Likes

#5

Your test looks like it is working. I will restart node-red again.

0 Likes

#6

Restarting node red didn't work for me. Thanks for testing anyway.

0 Likes

#7

Everything is matching now. Crazy!:laughing:

0 Likes

#8

which version of dashboard are you using ?
There was a fix in this area in version 2.9.4.
If more recent do you have an example flow you can share to demo the problem ? Thanks

0 Likes

#9

I have version 2.9.1. I do not know how to update anything while it is running on a Windows machine.

0 Likes

#10

Either just re-install it via the command line - or use the menu - manage palette entry to find it and update it.
image

0 Likes

#11

I have not tried to restart but at first attempt I had exactly the same running on a Pi with dash version 2.9.4

Regards

0 Likes

#12

It could have been a browser caching issue....

0 Likes

#13

This is what I am now experiencing.

Initial loading of UI:
image

After I refresh the browser:
image

I will go ahead and update to the latest version. How do I handle browser caching?

Thanks,
Mike

0 Likes

#14

You might have to look at the preferences.

  • Chrome (on a mac) you need to go to Preferences -> Advanced -> Privacy and security and you will see th e option at the bottom.
  • Safari go to preferences -> Advanced and at the bottom check the box 'Show Develop menu in menu bar' then you will have a new tab 'Develop' and one of the options is 'Empty Caches'
  • FireFox go to Preferences->Privacy & Security -> Cookies and Site Data and you will find the option
0 Likes

#15

I cleared the cache and it fixed it. Thank you!

0 Likes

#16

Usually Ctrl+F5 will force a full reload of the page, ignoring anything already in the cache.

0 Likes

#17

Yes, after refreshing the page, it ignored the cache. I went ahead and cleared the cache so that I do not need to refresh the browser. I have a lot of kiosks that I would need to refresh after the weekend. :sweat_smile:
I will just need to clear the cache if I change anything major.

Thanks,
Mike

1 Like