Signal Texting Service - Getting Started

Hi, I'm having problems with getting past the registration step of using the Signal nodes. I've registered a Signal account with my Smartphone and that works fine, in that I can text with other users.
My problem is getting my Signal node to work so that I can send a text to my phone whenever an alert is detected in nodered. I find the instructions at nodered-contrib-signal-client (node) - Node-RED a bit vague at times.
I enter the details in the "request sms" node, as advised, and when I send it I get the following message in the debug window, as indicated that one might in the instructions:

"Signal client error: {"name":"HTTPError","code":402,"response":"<html>\n<head>\n<meta http-equiv=\"Content-Type\" content=\"text/html;charset=utf-8\"/>\n<title>Error 402 Payment Required</title>\n</head>\n<body><h2>HTTP ERROR 402 Payment Required</h2>\n<table>\n<tr><th>URI:</th><td>/v1/accounts/sms/code/+XXXXXXXXXX</td></tr>\n<tr><th>STATUS:</th><td>402</td></tr>\n<tr><th>MESSAGE:</th><td>Payment Required</td></tr>\n<tr><th>SERVLET:</th><td>io.dropwizard.jersey.setup.JerseyServletContainer-38874eb5</td></tr>\n</table>\n\n</body>\n</html>\n"}"

I follow the instructions to get the registration code via running the captcha process, which I do and complete several captcha screens, and then stops with a blank screen. I search for the "signalcaptcha" field in the developer screen, as suggested but cannot find a registration code. What I observe is as follows:
"signalcaptcha://" + token;
Help from anyone who's managed to get this working would be greatly appreciated.

I've read the instructions, but haven't tried this yet myself although I have experience reverse engineering systems. If in the developer screen you see "signalcaptcha://" + token;" listed, that means it's part of the code. I just opened the source code, and I'm seeing the same.

What this page does is that it uses google's recaptcha to have your system solve a captcha, and if it passes automatically the onToken function is called to redirect your browser to the signal app on your computer which uses the signalcaptcha:// protocol for communication. This node's goal is for you to intercept that message. The onToken code is visible in the debugger part of the developer tools. The tab that you need to get that information, is the console tab. There you will find something like "Navigating to signalcaptcha://[long list of characters with a token] was stopped because of an unknown protocol". The idea is that you grab that long list of characters that is the token, and post it to the node editor screen.

Hi afelix, thanks for the response. I followed your instructions and received the following:
Failed to launch 'signalcaptcha://03AGdBq2614jwWi8RxI04dNCvr generate.html: ...etc..' because the scheme does not have a registered handler.

Actually, I'm not quite sure how the captcha code is linked to the signal node because I run the captcha process independently, as per the instructions in the link; I feel there's something missing here.
Now, is the first part of the above (before the generate html:) the registration key or is the key a part of the data generated by the html? Whichever, this is not a neat approach to registering a service.

The token that you need is the part after signalcaptcha://, so the whole 03AGdBq2614jwWi8RxI04dNCvr...... part. This setup is simply to prove that you're not automating the registration process

I tried to use that in the registration node and got the following:

"Signal client error: {"name":"HTTPError","code":403,"response":{"code":403,"message":"HTTP 403 Forbidden"}}"

Checking the error code shows:" The HTTP 403 Forbidden client error status response code indicates that the server understood the request but refuses to authorize it."

I've got nodered running on my Pi4 and I do observe that the registration data is stored in the folder: $ /home/.node-red/signal/signal, although it's listed as being of only 1 byte in length ?? This would imply that the pi opened the file but had no response from the SIgnal server to write into it. Any suggestions?
It seems to me that the registration is being sent to the Signal server.

Sorry, no input from me at this point. I'd have to run everything myself to figure it out too.

I think that you may need to contact the author via GitHub at this stage.

Actually, this is the first I've seen of something that can link to Signal. Last time I looked, it wasn't possible to link to it.

Hopefully you can report back if you can get it working? I'd be interested.

Contacted the author - work in prorgess.

Hello pinode,
i don't really know what your problem is I am not familiar with this error message. But have you checked on GitHub? There are good discussions about registration problems. Partly also in issues that have already been solved. See

Especially this issue led to the solution of the captcha problem:

Feel free to post your own issues. It seems the developer community on GitHub is more active.

I'm getting the same 403 forbidden error

Have you got around this?

Did you follow the instructions in the linked issue above?

Shame this requires yet another phone number in order to work.

Yes - tried have got past the captcha issue, have the code sent to my landline. However, the 'register' node fails with a 303 forbidden error.