Slight *bug* with `change` node and the `add` button

I am starting to use the change node a bit more for changing messages.

But time and time again, I am needing to add a second field to the message body.
(Say topic)

The add (bottom left of the window) is now obscured by the enabled button.
(See picture)

Could the size of the scroll window be reduced so the add is above the enabled button?

Just asking.

What browser are you seeing this on? It looks like a styling bug in the CSS somewhere, potentially dealing with resolution somewhere to me. I use the change node like this on a daily base and it’s the first time seeing this. If you look closely the “delete field” button is also partially hidden.

Platform node red is installed on?
Version of node-res?
Platform you’re viewing this on?
What browser plus version of it?
Any special situations like are you using a browser on the device that runs node red through VNC?
What’s the screen resolution of the device running the browser?

As for a workaround, you’re dealing with two vertical scrollbars. One in the inner area that shows the rules (set/delete/... with editor for each), and an outer one for the node configuration field. To get so far down, put your mouse cursor to the top of the node config form (name field for example), then scroll down using your mouse wheel or equivalent. That moves the outer scrollbar instead.

Direct access all local.

Ubuntu 18.04 LTS
NR 1.0.3
SimpleTab Rename

Which firefox version would that be? Is likely relevant to reproduce it. Also screen resolution as it appears to fit the content to the limited space available and that’s why the double scroll bar happens. I might try to reproduce it tomorrow in a VM, if the resolution falls within common sizes

70.1 (The latest?) 64bit


I am guessing it is something like: 1368 x 786?

I don't know these new resolutions.
It is a HDMI monitor and it works out what is needed/being used

As things are "plug and play" (though I am not using windows) I have never really set the resolution.

How do I find it?
(P.S. Going off line very soon. The day has now started for everyone else and so I need to now get going.)

The min-height is probably set a bit too high for that node on "low" res screens - (and likewise the switch node). We can adjust it.

In Ubuntu standard setup it is Settings > Devices > Screen Display

1 Like

1360 x 768 resolution.

To me that is high.

1024x768 used to be high res. I never really got above that until I got into Ubunto and RasPis with their HDMI outputs.

That is what it started as and so I am happy with that.

I am only stating what I have, and the problem it is causing.
If it is not fixable, ok. If it can be adjusted: even better.