So the Node Red SmartLife Air Nodes appear to be abandoned or support is no longer done?

So the Node Red SmartLife Air Nodes appear to be abandoned or support is no longer done? I have tried to contact the author via his direct email (which he game me some time ago), but no response. Tried to contact him via GitHub, no response, been several days in both cases.

I have created a new id from scratch and tried to enable the nodes per directions, but no luck. Id and password are correct, the phone app works. But when the configuration node logs in, I either get an error in the log saying the account has been locked or disabled, and if I try to login to the dedicated web page, I am told my new id has no assigned password, or my id already exists, in either case I can't set the region or reset the access. Thus the configuration node ever authenticates.

Well, really a bummer, because using SmartLife Air you avoided the Tuya infrastructure/cloud, for smart devices that could not be Tasmota'd.

Anyone have similar experience? Oh, I am not the only one noting issues on GitHub with access issues, FYI.

Ya know, it was rock solid for some time. But now that I have this issue, it is frustrating because I am stuck in a logic loop... I can't get it working... again, because it is not working right now. The frustrating part, is the phone app is working, just fine, my id and password accepted, etc. It is only the authentication via the nodes that is just not, now, working. The support was proactive for years, but I guess something has changed on that end, because the original author has gone silent, at least so far.

Presumably these are Tuya devices ?

Why can you not just go through the standard Tuya nodes - once you have done the initial setup for the TUYAAPI then you do not have to do anything via the cloud after that - all comms is local


That maybe the only option given the current situation. I just found (at the time) using SmartLife Air easy to do. My initial experience with TUYA (in 2018) was not positive, with their locked down, cloud only methodology.

I now have a mix of SmartLife Air and Tasmota. Some of the form factors can't get to direct access to use Tasmota, and they have newer firmware so I can't trick them into using TUYA-Convert.

That was the issue I found when I tried that route

Until something changes, all current solutions (that don't use Tasmota type enabled devices) are subject to stop working at any time

I literally have a Pi talking to a Alexa to do most of my controlling from Node-RED and have pretty much given up on local control of cheap commercial switches (I'm in UK)

I bought a pre-flashed Tasmota switch once and bricked it within 5 minutes when I clicked on the link to update its firmware so i gave up on that path

Yeah, I have had good results with pre-flash Tasmota, and except for one S31 that just died for no clear reason. I have been able to flash a few myself, S31s, but if I can get things working with NR and SmartLife Air, that is fine by me, about half of my smart switches are the small round form factor that are a PITA to crack, and then unsafe IMHO. SmartLife Air worked great for about 2 years, until somehow my password got screwed up. The phone app is rock solid, it is only NR configuration that seems to be at issue.

I only purchase pre-flashed Tasmota from a guy here in the US, he runs CloudFree.

The only issue is he sells out pretty fast when he gets stock in.

With many in the US, NOT wanting to use Chinese solutions that are cloud dependent, I see a market opportunity for some US company to step in and cut into the Chinese market share. Everyday it seems the US based firms are seeing a strategic advantage to NOT do business with China. Now that the US is re-developing local IC production, initiated by IBM and others, there is a reasonable chance some type of comparable ESP8266 or like solution will result.

Well you can go down the route of doing the developer portal setup - once it is done the device no longer need to talk to the internet

I use this for my hydronic heat pump and it has been running fine with NR for the last 18 months


@craigcurtin, Thanks for the reference. That is the next step, is to try TUYA API, I am just NOT a fan of using anything that is not local by concept. But... that said, I am going to try what you suggested, keep it local. I suspect I will lose my phone app access I have now?

Yep if you want to cut off the Cloud control then you lose control - but you can have this in parallel with the app if you wish - in my case the app adds no value for my heatpump so i have cut it off from Internet access (at my firewall and by the mac address of the heatpump/TUYA chip)

If i re-enable that access i can then use the app as well as my NR system.

I have cut it off at the firewall to ensure they can not push any firmware updates etc to the system and break what i have in place


I setup the Tuya App add a device, everything working. But when imported the device in NR via the node configuration, using the correct virtual id and key... from TUYA cloud. I either get no connection or if I get connection I get no response from the device. So something is not right. There are several NR node packages, I guess the one I picked is not working right. I may just write some straight Javascript to validate just that aspect.

Yeah, disable at the firewall is where I plan to end up. Having the phone app is not critical when I can just pull but a custom dashboard via NR.

I use the tuya-smart-device contrib node and it works fine after following the directions to get the ID and then perform the link from the CLI


Ditto Just remember that you can only have ONE node attached to a device, so if you need the info on another flow or NR instance MQTT is your friend

Good reminder... I do recall per the API documentation, that the devices don't support multiple connection sessions per se. In fact, a few of the 'hacks' of the past relied on this limitation to do various things.

As for getting the ids/keys, had done that before long before I ever used SmartLife Air. My original flow used TUYA cloud, but I never completely finished it, because I found SmartLife Air. I used the tuya-cli wizard command to get the keys.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.