Spacer size unable to change from 1x1 to any other size (Solved)

Since i have updated to Node-red 2.1.0 and later updated to 2.1.1
I am unable to change Spacer size in the dashboard.

@knolleary Please check this issue and help !
the dashboard spacer does not change beyond 1x1, although it shows as accepting size change in edit mode, but once pressed done and deploy it remains same at 1x1

@zenofmud Sir, can you help me ?

I can't think of a reason for this not to work... Does it work if you use the layout tool ?

That's another issue, i never reported, I don't see the layout at all, its all blank unless a new TAB with only 6 wide default layout

my dashboard is recent update. 3.0.4 and node red is 2.1.1


How big is the group width?

I keep all my group widths at 58 to maximise my large screen TV space usage
I was able to change my spacer size upto group width (ie 58) until i recently upgraded to Node-Red 2.1.1 and upgrading Dashboard 3.0.4 also did not solve the issue.

Anyone can help me ?

I have the same issue, can't change the size of the spacer, always is 1x1.

1 Like

Happy to see that I am not alone. Unhappy that it is still not solved
Did it happen to you after upgrading node red to 2.1.1 ?

@hotNipi @zenofmud @knolleary

It does not happen to me. I just tried to figure out, what can cause this. And with no success.
Known that if you using that high value for group width, the layout tool fails to draw anything. (there is some hardcoded limit how much it handles. (if I remember correctly))
But does will affect if you can't use it , I don't know.

@hotNipi I have been using large group width (58) since i started using my large monitor for display, nearly 4 months back, and i did not have any issue then, i was able to draw a spacer even the size of 50 x 3, successfully,. it may be a coincidence, but i noticed the change after updating to Node Red 2.1.1 (not dashboard). interestingly, the spacers which were already at 5x1 are still holding 5x1 size, it is only new spacers i am unable to change the size

+1 .... I cannot set the group width higher than 30 tiles....

I’m on NR version 2.1.3 but I cannot say since when this happens as I didn’t change my dashboard since longer time. I have a group width of only 16, so it cannot be caused by that.

It looks like not only the size can’t be changed, but any property of the spacer is not applied (I tried to change the group and this also didn’t work for be).

This is really annoying because I have no possibility to change the layout as also the layout editor doesn’t work correctly for me, I always have the problem that I can’t move widgets.

Agree with the frustration part, a quick workaround I found was to have multiple spacers of 1x1 size, if if i require a spacer of 4x1, i just make 4 spacers of 1x1. so its extra work, but i can keep my dashboard pretty. Hope the Pros find a solution for this or atleast identify whats the problem

I am still struggling with this. unable to change the spacer size from 1x1 to any other size.

Apologies, but I have been unable to replicate this error so can't suggest anything.

1 Like

I have the exact same issue. I am using node red 2.1.3, with dashboard version 3.1.1.

Is there any way to debug this?

It might not be a solution per se, but if you use the drag and drop interface for the layout it helps.