Synology DS1019+ docker installed: how to connect?

Dear friends,
I'm new to Node-red and... kindly ask for an help.

Just installed the official docker on my new DS1019+ NAS. Below attached its instance, listening on port 1880. It runs and seems healthy.

But I cannot open the client: if I try launching I only get an ERR_CONNECTION_REFUSED ( is my local NAS address).

Do you know where I'm failing? Do I need calling a different URL?

Many thanks in advance!

You need to use port 32768 instead, as that it mapped to the container, you could also map it to 1880

You may also need to adjust the NAS's firewall depending on how you are set up.

I tried port 32768, but it doesn't work either (ERR_CONNECTION_CLOSED)

I tried completely disabling (for a moment;) the NAS firewall too... but nothing changed :frowning:

Is the container still running ?
Stop the container, change the port from 32768 to 1880.
Restart container and retry with :1880

I can stop the cointainer, and I can modify the "local port" (initially it is set to automatic, and changes every time).
Yet I think the local port is only use for the internal (container-NAS) communication, while the "container port" is the one which is meant to be used for client connections: and it is already set to 1880.
Nonetheless I tried forcing the local port to 1880, but nothing changed.
I did try to enable a further port (1881), so to have 2 listening ports (1880 and 1881), but I still cannot launch the client on neither of them :frowning:

Further infos: Node.js v8 package was already installed and running. I did install the "latest" official version of NodeRed docker.

The 'local' port means the port you can reach from the OS, which is mapped to a container port.
So if you map the local port 1880 to 1880, you can reach the 1880 from your browser.

Do not use automatic for services that use a port to communicate (node-red in this case).

Thanks again, bakman2, but... I've put now everything to 1880 and still does not work :frowning:

Restart the container and look at the log.
btw which docker file are you using ?

If you execute this on the commandline:

docker run -it -p 1880:1880 --name mynodered nodered/node-red-docker

a new (correct) container will be created (perhaps remove the one you have already else it will complain about the ports).